Rails 3.1.0RC4 start server problem

Hi guys,
When I trying to start server. I get following errors:

[email protected]:~/todo$ rails s
/home/user/.rvm/gems/[email protected]/gems/execjs-1.1.2/lib/
execjs/runtimes.rb:43:in autodetect': Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable) from /home/user/.rvm/gems/[email protected]/gems/ execjs-1.1.2/lib/execjs.rb:5:inmodule:ExecJS
from /home/user/.rvm/gems/[email protected]/gems/
execjs-1.1.2/lib/execjs.rb:4:in <top (required)>' from /home/user/.rvm/gems/[email protected]/gems/coffee- script-2.2.0/lib/coffee_script.rb:1:inrequire’
from /home/user/.rvm/gems/[email protected]/gems/coffee-
script-2.2.0/lib/coffee_script.rb:1:in <top (required)>' from /home/user/.rvm/gems/[email protected]/gems/coffee- script-2.2.0/lib/coffee-script.rb:1:inrequire’
from /home/user/.rvm/gems/[email protected]/gems/coffee-
script-2.2.0/lib/coffee-script.rb:1:in <top (required)>' from /home/user/.rvm/gems/[email protected]/gems/ actionpack-3.1.0.rc4/lib/sprockets/railtie.rb:6:inrequire’
from /home/user/.rvm/gems/[email protected]/gems/
actionpack-3.1.0.rc4/lib/sprockets/railtie.rb:6:in using_coffee?' from /home/user/.rvm/gems/[email protected]/gems/ actionpack-3.1.0.rc4/lib/sprockets/railtie.rb:12:inclass:Railtie
from /home/user/.rvm/gems/[email protected]/gems/
actionpack-3.1.0.rc4/lib/sprockets/railtie.rb:4:in
<module:Sprockets>' from /home/user/.rvm/gems/[email protected]/gems/ actionpack-3.1.0.rc4/lib/sprockets/railtie.rb:1:in<top (required)>’
from /home/user/.rvm/gems/[email protected]/gems/
actionpack-3.1.0.rc4/lib/action_controller/railtie.rb:7:in require' from /home/user/.rvm/gems/[email protected]/gems/ actionpack-3.1.0.rc4/lib/action_controller/railtie.rb:7:in<top
(required)>’
from /home/user/.rvm/gems/[email protected]/gems/
activerecord-3.1.0.rc4/lib/active_record/railtie.rb:9:in require' from /home/user/.rvm/gems/[email protected]/gems/ activerecord-3.1.0.rc4/lib/active_record/railtie.rb:9:in<top
(required)>’
from /home/user/.rvm/gems/[email protected]/gems/
railties-3.1.0.rc4/lib/rails/all.rb:11:in require' from /home/user/.rvm/gems/[email protected]/gems/ railties-3.1.0.rc4/lib/rails/all.rb:11:inblock in <top (required)>’
from /home/user/.rvm/gems/[email protected]/gems/
railties-3.1.0.rc4/lib/rails/all.rb:5:in each' from /home/user/.rvm/gems/[email protected]/gems/ railties-3.1.0.rc4/lib/rails/all.rb:5:in<top (required)>’
from /home/user/apps/freekino/config/application.rb:3:in require' from /home/user/apps/freekino/config/application.rb:3:in<top
(required)>’
from /home/user/.rvm/gems/[email protected]/gems/
railties-3.1.0.rc4/lib/rails/commands.rb:52:in require' from /home/user/.rvm/gems/[email protected]/gems/ railties-3.1.0.rc4/lib/rails/commands.rb:52:inblock in <top
(required)>’
from /home/user/.rvm/gems/[email protected]/gems/
railties-3.1.0.rc4/lib/rails/commands.rb:49:in tap' from /home/user/.rvm/gems/[email protected]/gems/ railties-3.1.0.rc4/lib/rails/commands.rb:49:in<top (required)>’
from script/rails:6:in require' from script/rails:6:in

Please help me!

On 6/10/2011 10:05 AM, Zoloo wrote:

from /home/user/.rvm/gems/[email protected]/gems/
actionpack-3.1.0.rc4/lib/sprockets/railtie.rb:6:in require' actionpack-3.1.0.rc4/lib/action_controller/railtie.rb:7:inrequire’
from /home/user/.rvm/gems/[email protected]/gems/
from /home/user/.rvm/gems/[email protected]/gems/

Not sure if this is the best way going forward – but to get you going
now add the following line to your Gemfile and bundle install

gem ‘therubyracer’


Jack C.
[email protected]

i believe you need a javascript engine to run your code…

try installing rubyracer as Jack said… I had a similar problem once
and it
worked

2011/6/10 Jack C. [email protected]

   from /home/user/.rvm/gems/[email protected]/gems/

script-2.2.0/lib/coffee-script.rb:1:in <top (required)>' actionpack-3.1.0.rc4/lib/sprockets/railtie.rb:1:in<top (required)>’
from /home/user/.rvm/gems/[email protected]/gems/
from /home/user/.rvm/gems/[email protected]/gems/


Pedro Henrique de Souza Medeiros

Install nodejs

sudo apt-get install nodejs

In your Gemfile

write this

gem ‘execjs’

gem ‘therubyracer’

and then run

bundle install

everything works fine for me :slight_smile:

Thanks. It’s working.

On Sat, Jun 11, 2011 at 8:44 AM, Alex K. [email protected]
wrote:

[email protected]:~/todo$ rails s
from /home/user/.rvm/gems/[email protected]/gems/coffee-
actionpack-3.1.0.rc4/lib/sprockets/railtie.rb:12:in <class:Railtie>' from /home/user/.rvm/gems/[email protected]/gems/ from /home/user/.rvm/gems/[email protected]/gems/ railties-3.1.0.rc4/lib/rails/commands.rb:49:intap’
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to
[email protected]
For more options, visit this group at
http://groups.google.com/group/rubyonrails-talk?hl=en.


Best wishes,
Zolzaya E. - Developer

“USI” LLC
Building of Enkhuud center, 4th khoroo, 15th khoroolol
Bayanzurkh district, Ulaanbaatar - 51, Mongolia

Mobile: (976) 99796493
Phone: (976) 70151145
Fax: (976) 70141146

Yes its working now after adding that particular gems to gemlist.

Thank you Manish N.:slight_smile:

Manish N. wrote in post #1009188:

In your Gemfile

write this

gem ‘execjs’

gem ‘therubyracer’

and then run

bundle install

everything works fine for me :slight_smile:

thanks Manish N…

everything works fine for me as well:)

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs