Rails 2.3, restful_authentication, and passenger


#1

I can no longer login using the latest passenger + Rails 2.3 with the
restful_authentication plugin. If I run a quick “script/server”
everything is fine. Anyone else having trouble with this?


#2

On Tue, Mar 17, 2009 at 5:03 AM, yaphi removed_email_address@domain.invalid wrote:

I can no longer login using the latest passenger + Rails 2.3 with the
restful_authentication plugin. If I run a quick “script/server”
everything is fine. Anyone else having trouble with this?

Hi, did you update your project configuration files? i.e. rake
rails:update

-Conrad


#3

Yup. I did that, upgraded to Passenger 2.1.2 (which Rails 2.3
required)


#4

On Tue, Mar 17, 2009 at 12:09 PM, yaphi removed_email_address@domain.invalid wrote:

Hi, did you update your project configuration files? i.e. rake
rails:update

-Conrad

Hi, did you verify that restful_authentication plugin is compatible with
Rails 2.3.2?
I tend to make a copy of my rails project and experiment with the copy
when
moving
to the next release.

-Conrad


#5

That’s the funny part. I get no errors it just spits me back to the
login screen. I’m digging into it now and hopefully I find something.


#6

Yeah it works when I run script/server which is using mongrel I guess?
Won’t work with my local passenger install. I’ll just wait a while
maybe there’s something that changed.


#7

On Tue, Mar 17, 2009 at 12:48 PM, yaphi removed_email_address@domain.invalid wrote:

required)

rails:update
-Conrad

Hi, when you say won’t work, you should provide any information about
the
error
messages that you’re seeing in the web browser or log file. This will
help
people
help you.

-Conrad


#8

That could very well be it because yes I forgot to do that. Thank you.


#9

That did it! So anyone reading this, don’t forget to “passenger-
install-apache2-module” after running a gem update for 2.1.2
Thanks Matt.


#10

As a sanity check, did you update the location of Passenger in your
Apache config?
I’ve made that mistake…

–Matt J.