Rails 2.3.2 & MySQL and/or PostgreSQL


#1

very noob like question here. I’m getting back into learning rails
development. I fired my ruby text editor and made the appropriate gem
updates. I tried making a connection to MySQL which is my typical
development DB of choice and I can’t seem to get it working. I’ve
scoured the net implementing various methods but to without luck.

I was hoping for someone to point me in the right direction on getting
my development environment back to working fashion.

I’m running Windows 7, MySQL (Preferred) and/or PostgreSQL


#2

Bryan wrote:

very noob like question here. I’m getting back into learning rails
development. I fired my ruby text editor and made the appropriate gem
updates. I tried making a connection to MySQL which is my typical
development DB of choice and I can’t seem to get it working. I’ve
scoured the net implementing various methods but to without luck.

I was hoping for someone to point me in the right direction on getting
my development environment back to working fashion.

We can’t say much without additional information. What errors are you
seeing?

From the top of my head, have you enabled TCP/IP connections on your
MySQL Server? Rails won’t use named pipes or domain sockets on Windows.


Roderick van Domburg
http://www.nedforce.com


#3

Here is what I have done:

  1. rails myproject name
  2. edit database.yml file:
    development:
    adapter: mysql
    encoding: utf8
    reconnect: false
    database: mysql_development
    pool: 5
    username: root
    password: Password01
    host: localhost
  3. rake db:create

Error:
!!! The bundled mysql.rb driver has been removed from Rails 2.2.
Please install the mysql gem and try again: gem install mysql.

rake aborted!

126: The specified module could not be found. - C:/Ruby/lib/ruby/
gems/1.8/gems/mysql-2.7.3-x86-mswin32/ext/mysql.so

Note: the mysql.so file is physically located in that directory. I
have run gem install mysql but no luck.

On Apr 2, 10:33 am, Roderick van Domburg <rails-mailing-l…@andreas-


#4

The error message u’re getting would be helpful in trying to help you


#5

check your mysql database version,mysql 5.0 is a stable
version.Install that and check.


#6

Obviously you are on windows and I am quite rusty on on windows/ruby
on rails development so this may or may not work.

Can you connect to MySQL from command line? Install MySQL command
line client if you haven’t done so already and try to connect to your
mysql database. If you can then this is a gem installation problem.
Also, I don’t see a TCP/IP socket statement in your database.yml as in
this example file below:

development:
adapter: mysql
encoding: utf8
database: rubyweblog_development
username: root
password:
socket: /var/run/mysqld/mysqld.sock <-- this statement is missing
in your database.yml

I am not sure what the Windows equivalent is anymore. If you have
installed InstantRails then look it up in the database.yml that it
generates.

If you do get an error when using mysql command line client to connect
to mysql database then I would look there first. Typically, you have
to make sure that mysql/bin is in your windows path.

Hope this helps

Bharat


#7

Bharat-

Yes, I can successfully connect to mysql via command line. Yes, I
have added mysql to my windows path. I’m not using InstantRails- I
have installed everything piece by piece.

Deepali-
mysql 5.0 is stable.


#8

On Apr 2, 8:46 pm, Bryan removed_email_address@domain.invalid wrote:

126: The specified module could not be found. - C:/Ruby/lib/ruby/
gems/1.8/gems/mysql-2.7.3-x86-mswin32/ext/mysql.so

I’ve seen at least one person say that this can happen if the
permissions on mysql.so aren’t right (i think executable has to be
true or something).

Fred


#9

Fred,

I made sure that permissions on mysql.so have read/write on all groups/
users.

still getting the same error:
!!! The bundled mysql.rb driver has been removed from Rails 2.2.
Please install the mysql gem and try again: gem install mysql.

rake aborted!

126: The specified module could not be found. - C:/Ruby/lib/ruby/
gems/1.8/gems/mysql-2.7.3-x86-mswin32/ext/mysql.so

On Apr 6, 8:02 am, Frederick C. removed_email_address@domain.invalid


#10

While this does not bear directly on your present problem I suggest that
you at least consider installing cygwin for your Ruby development
environment. I found that the effort in getting the bits and pieces of
Ruby, Rails, various DBMS and gems to work on my MS-XP pro laptop was
greatly eased once I took the plunge.