Rails-2.3.2 and ruby-1.9.1 have problems with utf-8 chars using script/runner


#1

script/runner is called to deliver a mail by calling a ActionMailer
deliver method:
script/runner “Sitepost.deliver_dailycalea(Site.find(1), Time.utc
(2009,3,25)-246060)”

gives:

lib/commands/runner.rb:49:in eval': invalid byte sequence in US-ASCII (ArgumentError) from /opt/rails/gems/actionpack-2.3.2/lib/action_view/ template_error.rb:43:insource_extract’
from /opt/rails/gems/actionpack-2.3.2/lib/action_view/
template_error.rb:86:in compute_backtrace' from /opt/rails/gems/actionpack-2.3.2/lib/action_view/ template_error.rb:11:ininitialize’
from /opt/rails/gems/actionpack-2.3.2/lib/action_view/
template.rb:201:in new' from /opt/rails/gems/actionpack-2.3.2/lib/action_view/ template.rb:201:inrescue in render_template’
from /opt/rails/gems/actionpack-2.3.2/lib/action_view/
template.rb:194:in render_template' from /opt/rails/gems/actionpack-2.3.2/lib/action_view/base.rb: 260:inrender’
from /opt/rails/gems/actionmailer-2.3.2/lib/action_mailer/
base.rb:566:in render' from /opt/rails/gems/actionmailer-2.3.2/lib/action_mailer/ base.rb:552:inrender_message’
from /opt/rails/gems/actionmailer-2.3.2/lib/action_mailer/
base.rb:493:in create!' from /opt/rails/gems/actionmailer-2.3.2/lib/action_mailer/ base.rb:452:ininitialize’
from /opt/rails/gems/actionmailer-2.3.2/lib/action_mailer/
base.rb:395:in new' from /opt/rails/gems/actionmailer-2.3.2/lib/action_mailer/ base.rb:395:inmethod_missing’
from (eval):1:in <top (required)>' from /opt/rails/gems/rails-2.3.2/lib/commands/runner.rb:49:ineval’
from /opt/rails/gems/rails-2.3.2/lib/commands/runner.rb:49:in
<top (required)>' from ./script/runner:3:inrequire’
from ./script/runner:3:in `’