Rails 2.2.3-1 Problem

After installing the rails I faced this problem. If anyone aware of this
problem, kindly give solution for this.

[email protected]:~/public_html/Isync$ ./script/server
=> Booting WEBrick…
/usr/local/lib/site_ruby/1.8/rubygems.rb:149:in activate': can't activate activeresource (= 2.3.4, runtime), already activated activeresource-2.1.0 (Gem::Exception) from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:35:inrequire’
from
/xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:509:in
require' from /xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:354:innew_constants_in’
from
/xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:509:in
require' from ./script/../config/../vendor/rails/railties/lib/initializer.rb:222:inrequire_frameworks’
from
./script/…/config/…/vendor/rails/railties/lib/initializer.rb:222:in
each' from ./script/../config/../vendor/rails/railties/lib/initializer.rb:222:inrequire_frameworks’
from
./script/…/config/…/vendor/rails/railties/lib/initializer.rb:113:in
process' from ./script/../config/../vendor/rails/railties/lib/initializer.rb:93:insend’
from
./script/…/config/…/vendor/rails/railties/lib/initializer.rb:93:in
run' from /xhome/vellingiri/public_html/Isync/config/environment.rb:14 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
require' from /xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:509:inrequire’
from
/xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:354:in
new_constants_in' from /xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:509:inrequire’
from
/xhome/vellingiri/public_html/Isync/vendor/rails/railties/lib/commands/servers/webrick.rb:59
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:509:in
require' from /xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:354:innew_constants_in’
from
/xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:509:in
require' from /xhome/vellingiri/public_html/Isync/vendor/rails/railties/lib/commands/server.rb:39 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require’
from ./script/server:3

On 18 Sep 2009, at 09:11, Arul hari wrote:

After installing the rails I faced this problem. If anyone aware of
this
problem, kindly give solution for this.

Usually means that something else in your app loaded a specific
version of activeresource prior to rails loading it.

Fred

Frederick C. wrote:

On 18 Sep 2009, at 09:11, Arul hari wrote:

After installing the rails I faced this problem. If anyone aware of
this
problem, kindly give solution for this.

Usually means that something else in your app loaded a specific
version of activeresource prior to rails loading it.

Fred

I just installed rails 2.2.3-1. When I created the new application rails
created default directories.
#./script/server
/usr/local/lib/site_ruby/1.8/rubygems.rb:270:in activate': undefined methodmap’ for nil:NilClass (NoMethodError)
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:35:in
require' from /xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:509:inrequire’
from
/xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:354:in
new_constants_in' from /xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:509:inrequire’
from
./script/…/config/…/vendor/rails/railties/lib/initializer.rb:222:in
require_frameworks' from ./script/../config/../vendor/rails/railties/lib/initializer.rb:222:ineach’
from
./script/…/config/…/vendor/rails/railties/lib/initializer.rb:222:in
require_frameworks' from ./script/../config/../vendor/rails/railties/lib/initializer.rb:113:inprocess’
from
./script/…/config/…/vendor/rails/railties/lib/initializer.rb:93:in
send' from ./script/../config/../vendor/rails/railties/lib/initializer.rb:93:inrun’
from /xhome/vellingiri/public_html/Isync/config/environment.rb:13
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:509:in
require' from /xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:354:innew_constants_in’
from
/xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:509:in
require' from /xhome/vellingiri/public_html/Isync/vendor/rails/railties/lib/commands/servers/webrick.rb:59 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
require' from /xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:509:inrequire’
from
/xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:354:in
new_constants_in' from /xhome/vellingiri/public_html/Isync/vendor/rails/activesupport/lib/active_support/dependencies.rb:509:inrequire’
from
/xhome/vellingiri/public_html/Isync/vendor/rails/railties/lib/commands/server.rb:39
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from ./script/server:3

Regards,
S.Vellingiri.

On Fri, Sep 18, 2009 at 3:11 AM, Arul hari
[email protected] wrote:

After installing the rails I faced this problem. If anyone aware of this
problem, kindly give solution for this.

[email protected]:~/public_html/Isync$ ./script/server
=> Booting WEBrick…
/usr/local/lib/site_ruby/1.8/rubygems.rb:149:in `activate’: can’t
activate activeresource (= 2.3.4, runtime), already activated
activeresource-2.1.0 (Gem::Exception)

Do you get the same error when running script/console ?

I would remove whatever gems I wasn’t using… looks like you have at
least a couple versions of Rails installed. If the extra versions
aren’t there they can’t be loaded to cause the error. Removing them
fixed similar issues for me a while back.


Greg D.
http://destiney.com/

Greg D. wrote:

On Fri, Sep 18, 2009 at 3:11 AM, Arul hari
[email protected] wrote:

After installing the rails I faced this problem. If anyone aware of this
problem, kindly give solution for this.

[email protected]:~/public_html/Isync$ ./script/server
=> Booting WEBrick…
/usr/local/lib/site_ruby/1.8/rubygems.rb:149:in `activate’: can’t
activate activeresource (= 2.3.4, runtime), already activated
activeresource-2.1.0 (Gem::Exception)

Do you get the same error when running script/console ?

I would remove whatever gems I wasn’t using… looks like you have at
least a couple versions of Rails installed. If the extra versions
aren’t there they can’t be loaded to cause the error. Removing them
fixed similar issues for me a while back.


Greg D.
http://destiney.com/

When I use the script/console I got the same error,
ERROR:
[email protected]:~/public_html/Isync$ ./script/console
Loading development environment (Rails 2.1.0)
/xhome/vellingiri/public_html/Isync/vendor/rails/railties/lib/commands/console.rb:32:
warning: Insecure world writable dir /home/vellingiri in PATH, mode
040777
/usr/local/lib/site_ruby/1.8/rubygems.rb:270:in
activate':NoMethodError: undefined methodmap’ for nil:NilClass

User
NameError: uninitialized constant User
from
/xhome/vellingiri/public_html/Isync/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:278:in
load_missing_constant' from /xhome/vellingiri/public_html/Isync/vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:467:inconst_missing’
from
/xhome/vellingiri/public_html/Isync/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:479:in
`const_missing’
from (irb):1

Regards,
S.Vellingiri.

On Sep 18, 8:26 am, Arul hari [email protected]
wrote:

Fred
`require’
This error message makes it hard to believe that you just “created a
new application” - you’ve got a frozen version of Rails in vendor/
rails. Likely this is causing the problem. The 2.1-era gem loader had
some issues with gems that depended on Rails throwing errors when
Rails was vendored.

It’s also possible that your Rubygems install is out of date - see the
documentation on gem update --system for more details.

–Matt J.

2009/9/19 Arul hari [email protected]:

/usr/local/lib/site_ruby/1.8/rubygems.rb:149:in `activate’: can’t


Greg D.
http://destiney.com/

When I use the script/console I got the same error,
ERROR:
 [snip]

Did you try removing gems you don’t need? Do gem list to see what you
have got then gem uninstall to remove any old ones.
(http://rubygems.org/read/chapter/10#page38).

Colin

Colin L. wrote:

2009/9/19 Arul hari [email protected]:

/usr/local/lib/site_ruby/1.8/rubygems.rb:149:in `activate’: can’t


Greg D.
http://destiney.com/

When I use the script/console I got the same error,
ERROR:
[snip]

Did you try removing gems you don’t need? Do gem list to see what you
have got then gem uninstall to remove any old ones.
(http://rubygems.org/read/chapter/10#page38).

Colin

Dear Friends,
Now the old rails application is working fine. I have re-created
the rails application with existing one. For instance rails
/home/vellingiri/Isync. I did not overwrite the controller part, the
remaining part I created the new file.

It was working successfully. When I created the new application it was
throwing the error in apache “Object not found” . I have checked the
apache log file. File not found error is there.

ERROR:
Pagination is not working properly in old rails application itself.
it returns the following error.

NoMethodError in PatchController#project_details

undefined method `paginate’ for #PatchController:0xb7b2ff18

RAILS_ROOT: /xhome/vellingiri/public_html/vellingirinewpatch

If any one aware of this error, please give some idea about on this.

Regards,
S.Vellingiri.

2009/9/21 Arul hari [email protected]:

Dear Friends,
  Now the old rails application is working fine. I have re-created
the rails application with existing one. For instance rails
/home/vellingiri/Isync. I did not overwrite the controller part, the
remaining part I created the new file.

For the record what was it that fixed the original problem?

undefined method `paginate’ for #PatchController:0xb7b2ff18

RAILS_ROOT: /xhome/vellingiri/public_html/vellingirinewpatch

Have you remembered to install will_paginate?
Google for mislav-will_paginate if you don’t know what this is.

Colin

Colin L. wrote:

2009/9/21 Arul hari [email protected]:

Dear Friends,
  Now the old rails application is working fine. I have re-created
the rails application with existing one. For instance rails
/home/vellingiri/Isync. I did not overwrite the controller part, the
remaining part I created the new file.

For the record what was it that fixed the original problem?

undefined method `paginate’ for #PatchController:0xb7b2ff18

RAILS_ROOT: /xhome/vellingiri/public_html/vellingirinewpatch

Have you remembered to install will_paginate?
Google for mislav-will_paginate if you don’t know what this is.

Colin

I have installed both gem packages ( will_paginate, mislav-will_paginate
). It was installed successfully. Also I have required the module in
environment.rb file. Still the same problem is persists. Even if I take
out the require from the environment file, the same error is coming. Any
ideas?

MESSAGE:
[email protected]:~/public_html/vellingirinewpatch$ gem
install will_paginate
Successfully installed will_paginate-2.2.2
1 gem installed
Installing ri documentation for will_paginate-2.2.2…
Installing RDoc documentation for will_paginate-2.2.2…
[email protected]:~/public_html/vellingirinewpatch$ gem install
mislav-will_paginate
ERROR: could not find gem mislav-will_paginate locally or in a
repository
[email protected]:~/public_html/vellingirinewpatch$ vim /et
etc/ etc.tar.gz
[email protected]:~/public_html/vellingirinewpatch$ vim config/envi
environment.rb environments/
[email protected]:~/public_html/vellingirinewpatch$ vim
config/environment.rb
require ‘will_paginate’

Checked the log file:
NoMethodError (undefined method paginate' for #<PatchController:0xb77a30d4>): /app/controllers/patch_controller.rb:172:inpatch_details’
/vendor/rails/actionpack/lib/action_controller/base.rb:1162:in
send' /vendor/rails/actionpack/lib/action_controller/base.rb:1162:inperform_action_without_filters’
/vendor/rails/actionpack/lib/action_controller/filters.rb:580:in
call_filters' /vendor/rails/actionpack/lib/action_controller/filters.rb:573:inperform_action_without_benchmark’
/vendor/rails/actionpack/lib/action_controller/benchmarking.rb:68:in
perform_action_without_rescue' /usr/lib/ruby/1.8/benchmark.rb:293:inmeasure’
/vendor/rails/actionpack/lib/action_controller/benchmarking.rb:68:in
perform_action_without_rescue' /vendor/rails/actionpack/lib/action_controller/rescue.rb:201:inperform_action_without_caching’
/vendor/rails/actionpack/lib/action_controller/caching/sql_cache.rb:13:in
perform_action' /vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/query_cache.rb:33:incache’
/vendor/rails/activerecord/lib/active_record/query_cache.rb:8:in
cache' /vendor/rails/actionpack/lib/action_controller/caching/sql_cache.rb:12:inperform_action’
/vendor/rails/actionpack/lib/action_controller/base.rb:529:in send' /vendor/rails/actionpack/lib/action_controller/base.rb:529:inprocess_without_filters’
/vendor/rails/actionpack/lib/action_controller/filters.rb:569:in
process_without_session_management_support' /vendor/rails/actionpack/lib/action_controller/session_management.rb:130:inprocess’
/vendor/rails/actionpack/lib/action_controller/base.rb:389:in
process' /vendor/rails/actionpack/lib/action_controller/dispatcher.rb:149:inhandle_request’
/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:107:in
dispatch' /vendor/rails/actionpack/lib/action_controller/dispatcher.rb:104:insynchronize’
/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:104:in
dispatch' /vendor/rails/actionpack/lib/action_controller/dispatcher.rb:120:indispatch_cgi’
/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:35:in
`dispatch’
/var/www/vellingiri/vellingirinewpatch/public/dispatch.cgi:12

Regards,
S.Vellingiri.

Colin L. wrote:

2009/9/21 Arul hari [email protected]:

For the record what was it that fixed the original problem?
You did not answer this question. You should provide feedback here so
that others with similar problems who find this thread will know the
solution

Colin
install will_paginate
Successfully installed will_paginate-2.2.2
1 gem installed
Installing ri documentation for will_paginate-2.2.2…
Installing RDoc documentation for will_paginate-2.2.2…
[email protected]:~/public_html/vellingirinewpatch$ gem install
mislav-will_paginate
ERROR: Â could not find gem mislav-will_paginate locally or in a
repository

You say you installed both but the this says it did not install
mislav, but it installed will_paginate so it should be ok.
What does ‘gem list’ show?

[email protected]:~/public_html/vellingirinewpatch$ vim /et
etc/ Â Â Â Â etc.tar.gz
[email protected]:~/public_html/vellingirinewpatch$ vim config/envi
environment.rb  environments/
[email protected]:~/public_html/vellingirinewpatch$ vim
config/environment.rb
require ‘will_paginate’

Can you post environment.rb, it is not clear from above what you have
there.
Also post the section of the controller that generate the undefined
method error.

Checked the log file:
 NoMethodError (undefined method paginate' for #<PatchController:0xb77a30d4>):   /app/controllers/patch_controller.rb:172:inpatch_details’

You should not have had to check the log file, this should have
appeared in the browser. Are you running in development mode?

Colin

Dear Friends,
This is the way I correct my rails problem.

Ruby On Rails configuration:

  1. Installation
  2. Configuration

  1. Installation:
  ----------------
  The required packages are,
      rails
      eruby (Embedded Ruby Language)
      libapache2-mod-ruby ( Embedding Ruby in the Apache2 web server
                  mod_ruby embeds the Ruby interpreter into the 

Apache2 web server,
allowing Ruby CGI scripts to be executed natively.
These scripts will
start up much faster than without mod_ruby. )
postgresql-7.4-plruby
postgresql-plruby
ruby
ruby1.8
ruby1.9
rubygems

  2. Configuration:
  ------------------
     * After this installation did some changes in the 

sites-enabled/000-default
DocumentRoot /var/www/html/
#
# Options FollowSymLinks
# AllowOverride All
#
<Directory /var/www/html/>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
# This directive allows us to have apache2’s default start
page
# in /apache2-default/, but still have / go to the right
place
# RedirectMatch ^/$ /apache2-default/

After done this changes , I restarted the apache2 manually. Created the
new rails application. After creating checked whether all the files and
directories has been created or not. Except .htaccess file , all the
files and directory has created. Modify the source code.

Find out the configuration file as follows,
/usr/share/rails/railties/lib/rails_generator/generators/applications
m.template “configs/apache.conf”, “public/.htaccess” #added this
line

Created new rails application
It was creating successfully with all the depend directories.
For existing application we have to call rails , It will ask the confirmation to overwrite the file.
Exclude app directory and public we could overwrite all the fie files
and directories. Then old application also working fine.

   This is what I have corrected my mistake. Thanks to everyone to 

make this work successful.

Regards,
S.Vellingiri

2009/9/21 Arul hari [email protected]:

For the record what was it that fixed the original problem?
You did not answer this question. You should provide feedback here so
that others with similar problems who find this thread will know the
solution

Colin
install will_paginate
Successfully installed will_paginate-2.2.2
1 gem installed
Installing ri documentation for will_paginate-2.2.2…
Installing RDoc documentation for will_paginate-2.2.2…
[email protected]:~/public_html/vellingirinewpatch$ gem install
mislav-will_paginate
ERROR: Â could not find gem mislav-will_paginate locally or in a
repository

You say you installed both but the this says it did not install
mislav, but it installed will_paginate so it should be ok.
What does ‘gem list’ show?

[email protected]:~/public_html/vellingirinewpatch$ vim /et
etc/ Â Â Â Â etc.tar.gz
[email protected]:~/public_html/vellingirinewpatch$ vim config/envi
environment.rb  environments/
[email protected]:~/public_html/vellingirinewpatch$ vim
config/environment.rb
require ‘will_paginate’

Can you post environment.rb, it is not clear from above what you have
there.
Also post the section of the controller that generate the undefined
method error.

Checked the log file:
 NoMethodError (undefined method paginate' for #<PatchController:0xb77a30d4>):   /app/controllers/patch_controller.rb:172:inpatch_details’

You should not have had to check the log file, this should have
appeared in the browser. Are you running in development mode?

Colin

On Fri, Mar 18, 2011 at 6:38 PM, Pablo Tomas B.
[email protected]wrote:

/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:33:in `require’

activerecord (2.2.3)
railroad (0.5.0)
The app works Ok at my development box, not at the VPS hosting.

Please post your environment

OS, rubygems , webserver

I dont know guys how you fixed this problem. I have one rails app that
runs as expected at port 80 using webrick. And another rails app running
at port 3001, that doesnt start. I get the same error as you:

ruby script/server -p 3001 -e production &
[2] 29028
[email protected]:/home/magic/delivery/workspace/delivery-magic-wap#
/usr/local/lib/site_ruby/1.8/rubygems.rb:232:in activate': undefined methodmap’ for nil:NilClass (NoMethodError)
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:33:in require' from /home/magic/delivery/workspace/delivery-magic-wap/vendor/rails/railties/lib/commands/server.rb:1 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:29:ingem_original_require’
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:29:in `require’
from script/server:3

I uninstalled the multiple rails versions I had, and left the one that
works for the other app 2.2.3. This is my gem list output:

gem list

*** LOCAL GEMS ***

actionmailer (2.2.3)
actionpack (2.2.3)
activemerchant (1.10.0)
activerecord (2.2.3)
activeresource (2.2.3)
activesupport (3.0.5, 2.2.3)
authlogic (2.1.6)
braintree (2.8.0)
builder (3.0.0)
i18n (0.4.2)
jabber4r (0.8.0)
json (1.5.1)
linecache (0.43)
rack (1.1.2, 1.0.1)
railroad (0.5.0)
rails (2.2.3)
rake (0.8.7)
ruby-debug-base (0.10.4)
ruby-debug-ide (0.4.16)
rubygems-update (1.4.2)
xmpp4r (0.5)

Everything seems ok, but I still get this anoying error. I’m not using
apache, neither mongrel. Just trying to start with the default webrick…
The app works Ok at my development box, not at the VPS hosting.

Any clues and what could be wrong?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs