Rails 1.2 / Theme generator issue

I’m asking this question again, as there are some discussions going on.

I updated my Rails to 1.2.1 (gem update rails)

Started my rails app which has theme generator plugin and I get

following error

/script/…/config/…/vendor/plugins/theme_support/lib/patches/routeset_ex.rb:26:in
create_theme_routes': undefined methodnamed_route’ for
#ActionController::Routing::RouteSet:0x1313b78 (NoMethodError)
from
./script/…/config/…/vendor/plugins/theme_support/lib/patches/routeset_ex.rb:13:in
`draw’
from ./script/…/config/…/config/routes.rb:1

I tried following options

Moved routes to route.rb from theme_support/lib/patches/routeset_ex.rb

and clered the whole file

Forced RAILS_VERSION = 1.1.6 (basically rolled back the rails version)

Still I get above error.

Any one fixed this issue for sure?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs