Rails 1.2.6 to 2.0.2 Help

Hi,

I recently got a new server and installed all my necessary libraries
(gems). With the new libs came a new version of Rails.

I got everything configured (i think) and tried to start up the server
and got the following:


  * config.breakpoint_server has been deprecated and has no

effect.


Followed by lots of errors regarding: undefined method `require_gem’
for main:Object (NoMethodError)

What happened?

Also, I removed a ‘require’ statement from the environment.rb and got
the “config.breakpoint” warning and the server started up.

However, when I try and access the app I get: “500 Internal Server
Error”

Just commented out config.breakpoint in my development.rb file. Is
this OK?

No more error, but still getting “500 Internal Server Error”

Hmmm…

So, can I run 1.26 and 2.0.2 at the same time to support my legacy
apps?

Check your prod or dev log. It will help you.
The 500 error might be related to the new way rails deals with the
session. You need to add a line like this one in your environment.rb:
config.action_controller.session = { :session_key =>
“_app_session”, :secret => “something longer than 30 characters” }

I am also currently enjoying the damn hard migration to Rails2.

H

There’s no need to give up as it is most likely something simple.

Did you change all the require_gem method calls in config/boot.rb to
just
“gem”?

Did you set the session like Harry said?

Did you read what the last 50 lines of your development environment is
telling you?

I gave up. Sadly.

I froze Rails in 1.2.6 for my application.

So, now that I froze Rails, I can re-install 2.0.2 and all new apps
will use 2.0.2?

So, boot.rb didn’t have any ‘require_gem’ in it at all. I did not set
the session and I have not read the last 50 lines of my development
environment. BUT, I will do that now.

I thought I saw something that you could run and find out if anything
you have in your application was deprecated in 2.0.2. Does this
exist?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs