Rails 1.2.6 mongrel script\server error

When I try a newly created rails 1.2.6 application to mine surprise I
got the following error:

c:\Temp\Demo>ruby script\server
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_re quire': no such file to load -- c:/ruby/lib/ruby/gems/1.8/gems/ mongrel_service-0 .3.3-x86-mswin32-60/lib/mongrel_service/init.rb (MissingSourceFile) from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:inre
quire’
from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/
active_suppo
rt/dependencies.rb:495:in require' from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/ active_suppo rt/dependencies.rb:342:innew_constants_in’
from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/
active_suppo
rt/dependencies.rb:495:in require' from c:/ruby/lib/ruby/gems/1.8/gems/gem_plugin-0.2.3/lib/ gem_plugin.rb:1 34:inload’
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:
166:in eac h' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/source_index.rb: 166:ineac
h’
from c:/ruby/lib/ruby/gems/1.8/gems/gem_plugin-0.2.3/lib/
gem_plugin.rb:1
12:in load' ... 11 levels... from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.6/lib/commands/ server.rb:3 9 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:inge
m_original_require’
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `re
quire’
from script/server:3

Here is my environment:

c:\Temp\Demo>ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [i386-mswin32]

c:\Temp\Demo>rails -v
Rails 1.2.6

c:\Temp\Demo>gem -v
0.9.5

mongrel (1.1.1)

Yep, I have the same error; I’d be interested in finding out the
answer as well.

The error was not present on my ubuntu 7.10 server just on my XP.

You need to rename your latest installed mongrel 1.1.1 directory to be
c:/ruby/lib/ruby/gems/1.8/gems/mongrel_service-0.3.3-x86-mswin32-60
because it could not find the actual installed mongrel directory. It
should work after your installed directory is renamed.

I hope this would help you getting mongrel running.

Dan

This solves my problem, for now.
Thanks :slight_smile:

This solved it for me:

gem install mongrel_service -v0.3.3 --include-dependencies

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs