Rails-1.2.3 to 2.1.1 give memcache-client error


#1

my old project is in rails-1.2.3
i installed rails-2.1.1.gem
i changed RAILS_GEM_VERSION=‘2.1.1’ in environment.rb
i started script/server webrick
everything is fine

when i checked in browser http://localhost:3000
500 Internal Server Error
here is my log file(log/development.log)

DEPRECATION WARNING: config.action_view.cache_template_extensions option
has been deprecated and has no affect. Please remove it from your config
files. See http://www.rubyonrails.org/deprecation for details. (called
from send at
D:/pacs/ruby/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/initializer.rb:464)
DEPRECATION WARNING: The fragment_cache_store= method is now use
cache_store= See http://www.rubyonrails.org/deprecation for details.
(called from fragment_cache_store= at
D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/caching/fragments.rb:33)
DEPRECATION WARNING: Inflector is deprecated! Use
ActiveSupport::Inflector instead. See
http://www.rubyonrails.org/deprecation for details. (called from
D:/Projects/yfly_fresh/config/environment.rb:16)
/!\ FAILSAFE /!\ Fri Oct 03 12:33:05 +0530 2008
Status: 500 Internal Server Error
No connection to server
D:/pacs/ruby/lib/ruby/gems/1.8/gems/memcache-client-1.5.0/lib/memcache.rb:625:in
request_setup' D:/pacs/ruby/lib/ruby/gems/1.8/gems/memcache-client-1.5.0/lib/memcache.rb:204:inget’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/session/mem_cache_store.rb:61:in
initialize' D:/pacs/ruby/lib/ruby/1.8/cgi/session.rb:273:innew’
D:/pacs/ruby/lib/ruby/1.8/cgi/session.rb:273:in
initialize_without_cgi_reader' D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/cgi_ext/session.rb:39:ininitialize’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/cgi_process.rb:132:in
new' D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/cgi_process.rb:132:insession’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/cgi_process.rb:168:in
stale_session_check!' D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/cgi_process.rb:116:insession’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/base.rb:1139:in
assign_shortcuts_without_flash' D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/flash.rb:166:inassign_shortcuts’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/base.rb:523:in
process_without_filters' D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/filters.rb:568:inprocess_without_session_management_support’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/session_management.rb:130:in
process' D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/base.rb:389:inprocess’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/dispatcher.rb:149:in
handle_request' D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/dispatcher.rb:107:indispatch’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/dispatcher.rb:104:in
synchronize' D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/dispatcher.rb:104:indispatch’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/dispatcher.rb:120:in
dispatch_cgi' D:/pacs/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.1/lib/action_controller/dispatcher.rb:35:indispatch’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/webrick_server.rb:112:in
handle_dispatch' D:/pacs/ruby/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/webrick_server.rb:78:inservice’
D:/pacs/ruby/lib/ruby/1.8/webrick/httpserver.rb:104:in service' D:/pacs/ruby/lib/ruby/1.8/webrick/httpserver.rb:65:inrun’
D:/pacs/ruby/lib/ruby/1.8/webrick/server.rb:173:in start_thread' D:/pacs/ruby/lib/ruby/1.8/webrick/server.rb:162:instart’
D:/pacs/ruby/lib/ruby/1.8/webrick/server.rb:162:in start_thread' D:/pacs/ruby/lib/ruby/1.8/webrick/server.rb:95:instart’
D:/pacs/ruby/lib/ruby/1.8/webrick/server.rb:92:in each' D:/pacs/ruby/lib/ruby/1.8/webrick/server.rb:92:instart’
D:/pacs/ruby/lib/ruby/1.8/webrick/server.rb:23:in start' D:/pacs/ruby/lib/ruby/1.8/webrick/server.rb:82:instart’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/webrick_server.rb:62:in
dispatch' D:/pacs/ruby/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/commands/servers/webrick.rb:66 D:/pacs/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
D:/pacs/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' D:/pacs/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/active_support/dependencies.rb:510:inrequire’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/active_support/dependencies.rb:355:in
new_constants_in' D:/pacs/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/active_support/dependencies.rb:510:inrequire’
D:/pacs/ruby/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/commands/server.rb:39
D:/pacs/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' D:/pacs/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
./script/server:4
-e:2:in `load’
-e:2

is memcahe-client compatible with rails-2.1.1 ?
any help ?


#2

Status: 500 Internal Server Error
No connection to server

I had the same error, but I shamefully found out my memcached daemon
wasn’t running. A

memcached -u www-data

solved it all.

Hope this helps,
Michael