Rail_upgrade gem fails to recognise environment.rb

The rails 3 upgrade gem is refusing to generate a new application rb for
a
project i am trying to get onto rails 3.

Running: rake rails:upgrade:configuration --trace
Results in the following error:

There doesn’t seem to be a real environment.rb in your app. Are you
sure
config/environment.rb has the right contents?
/Users/robaldred/Sites/StardotSite/stardoteditor/vendor/plugins/rails_upgrade/lib/tasks/…/…/lib/new_configuration_generator.rb:29:in
`generate_new_application_rb’
/Users/robaldred/Sites/StardotSite/stardoteditor/vendor/plugins/rails_upgrade/lib/tasks/rails_upgrade_tasks.rake:37

Seems like the regex used to determine the environment.rb file is valid
is
failing to match the content in the file, please see the attached, it
looks
pretty normal to me. What am I missing, for now will just make an
application.rb manually.

Rob

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs