Rail 2.2.2 no instala en linux ubuntu

buenos dias.

por si depronto les ha pasado intento instalar rails en linux ubunto
7.04 server y se queda instalando:

[email protected]:~# export http_proxy=“http://172.20.49.51:80
[email protected]:~# gem install rails
Bulk updating Gem source index for: http://gems.rubyforge.org/
Bulk updating Gem source index for: http://gems.rubyforge.org/

sera que hay que hacer algo diferente?

gracias por la ayuda.

saludos

uenos dias.

logre la instalacion siguiendo este instructivo.

http://railsforum.com/viewtopic.php?pid=16102

mil gracias

disculpen, sigue el problema.

a pesar de que instala cuando escribo rails -v me genera error:

[email protected]:~# rails -v
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/vendor.rb:5:
undefined method gem' for main:Object (NoMethodError) from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequ
ire__’
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in requ ire' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support. rb:24 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequ
ire__’
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in requ ire' from /usr/lib/ruby/gems/1.8/gems/activerecord-2.2.2/lib/active_record.rb :25 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequ

Yo publiqué en tutorial en mi blog, puedes revisarlo en:
http://www.joserafael.com.ve/blog/index.php/2007/11/21/instalar_ruby_on_rails_en_ubuntu_gutsy

Aprendiz_ror Ruby on rails wrote:

disculpen, sigue el problema.

a pesar de que instala cuando escribo rails -v me genera error:

[email protected]:~# rails -v
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/vendor.rb:5:
undefined method gem' for main:Object (NoMethodError) from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequ
ire__’
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in requ ire' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support. rb:24 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequ
ire__’
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in requ ire' from /usr/lib/ruby/gems/1.8/gems/activerecord-2.2.2/lib/active_record.rb :25 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequ

Gracias Jose Rafael por tu respuesta esta muy bueno tu informacion, pero
ahora me genera el error siguiente, estoy por reinstalar todo, desde
linux para arriba.le dejo el error por si acaso, parece error de

[email protected]:~# sudo gem1.8 install mongrel
Building native extensions. This could take a while…
ERROR: Error installing mongrel:
ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb install mongrel
checking for main() in -lc… no
creating Makefile

make
cc -I. -I. -I/usr/lib/ruby/1.8/i486-linux -I. -fPIC
-fno-strict-aliasing -g -g
-O2 -fPIC -c http11.c
cc -I. -I. -I/usr/lib/ruby/1.8/i486-linux -I. -fPIC
-fno-strict-aliasing -g -g
-O2 -fPIC -c http11_parser.c
cc -shared -o http11.so http11.o http11_parser.o -L"." -L"/usr/lib" -L.
-Wl,-Bsy
mbolic-functions -rdynamic -Wl,-export-dynamic -lruby1.8 -lpthread
-ldl -lcr
ypt -lm -lc
/usr/bin/ld: unrecognized option ‘-Bsymbolic-functions’
/usr/bin/ld: use the --help option for usage information
collect2: ld returned 1 exit status
make: *** [http11.so] Error 1

Gem files will remain installed in
/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5 for
inspection.
Results logged to
/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/ext/http11/gem_make.
out
[email protected]:~#

Jorge Calás Lozano wrote:

sudo apt-get install ruby-dev

Gracias por tu ayuda. ya lo habia hecho y me genera lo siguiente:

[email protected]:~# sudo apt-get install ruby-dev
Leyendo lista de paquetes… Hecho
Creando árbol de dependencias
Reading state information… Hecho
E: No se pudo encontrar el paquete ruby-dev

saludos

sudo apt-get install ruby-dev

Sería

sudo apt-get install ruby1.8-dev

2009/3/18 Jorge Calás Lozano [email protected]

Hola Luis Felipe.

que bueno saber nuevamente de ti, pues habia perdido tu rastro.
regalame tu correo, el mio es [email protected] y ahora
tengo otro rol dentro del sena y necesito hablar contigo.

gracias por tu respuesta, pero tampoco me funciona. Me genera lo
siguiente:

[email protected]:~# sudo apt-get install ruby1.8-dev
Leyendo lista de paquetes… Hecho
Creando árbol de dependencias
Reading state information… Hecho
ruby1.8-dev ya está en su versión más reciente.
0 actualizados, 0 se instalarán, 0 para eliminar y 235 no actualizados.
[email protected]:~#

Buenas, reinstale linux y el error era en el paquete sudo apt-get
install ruby1.8-dev

ya en la nueva instalacion cuando me fallo la instalada de mongrel,
corri este paquete y listo.

no se por que fallaba este paquete, si lo intentaba instalar me decia
que ya estaba y tampoco se dejaba desinstalar.

gracias por sus aportes

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs