Radrails: workspace in use, choose a different one

I’ve just begun using Radrails and am experiencing a puzzling error.
When I
set my workspace to my home directory/some subdirectory, Radrails starts
correctly. I would like to set the workspace to /var/rails where I have
of my existing rails apps but Radrails fails to start with the error:
workspace in use, choose a different one. Any ideas? I want to edit the
in the directory in which it runs, thereby avoiding copying the modded
to the executable directory.


View this message in context:
Sent from the RubyOnRails Users forum at Nabble.com.

try removing/renaming the /var/rails/.metadata/.lock file and see if
corrects it.

if that doesn’t do anything, take a look in the current workspace
.metadata/.log file for a possible reason.

hope that helps.


Thanks for the tips. However there isn’t a .metadata directory in
I’ve never been able to set that as a workspace so it’s not surprising I
guess. I’ve looked at the .metadata/.log file in my current workspace
but I
can’t understand it.

View this message in context:
Sent from the RubyOnRails Users forum at Nabble.com.

I’m still having problems with this. I’ve searched everywhere and can’t
a solution that fits. I’ve just installed the latest version of Radrails
deleted the old workspace directory. I’m able to set various directories
my home directory as the workspace without error but I can’t set the
/var/rails directory or any of it’s subdirectories as the workspace. I
the “workspace in use” error. I’ve tried creating a sym link from my
directory to /var/rails but that doesn’t work either. I’ve searched for
.metadata directory in every directory I’ve tried to unsuccessfully set
the workspace and have yet to find one. It doesn’t appear to have
to do with a .lock file. When I set the workspace to a directory in my
directory it successfully creates the .metadata directory and the .lock
file. I keep all of my rails apps in /var/rails/ and use virtual servers
apache so I would like to be able to edit the files directly from the
/var/rails directory.

Does anyone have any ideas? I’m running Ubuntu 5.10

View this message in context:
Sent from the RubyOnRails Users forum at Nabble.com.

I was able to get the workspace set to /var/rails. What I did was set
workspace to /tmp then I copied the .metadata directory to /var/rails
deleted the .lock file. I had to chown -R the .metada directory to
stuart:stuart (my username:group) in order for Radrails to be able to
the .lock file.

I can now open and close Radrails and set /var/rails as the workspace.
However, I can’t create a new project. When I click on the “Finish”
the progress bar just flashes and nothing happens. The new project
just stays open and nothing happens.

I use eclipse for java dev so I’m no noob to the interface. I just can’t
this darn thing to work.

How about this problem? Any ideas?

View this message in context:
Sent from the RubyOnRails Users forum at Nabble.com.

Never mind me guys, it seems I’m finally getting some where. I finally
chown’d all the directories in /var/rails so eclipse could write to
That seemed to work. Thanks for the previous help.

View this message in context:
Sent from the RubyOnRails Users forum at Nabble.com.

try deleting the .lock file in your current workspace (with radrails NOT
running), then start radrails and try to change the workspace.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs