RadRails problems - any ideas


#1

Hi, I’ve followed the rad rails instructions for importing a project and
have two issues.

First my console tab shows “Console is not available” I don’t know if
that’s
significant or not, yet.
Second, I’ve created a WebBrick server, but it doesn’t respond when I
try to
start it from withing RadRails. There’s no error shown. I’m guessing it
can’t find it.

I’m on OSX and using the rad rails eclipse plugin on top of rdt.

thanks.


#2

I think the console says that until something is actually running in it.

When you say “created a WebBrick server”, do you mean you created a
project and tried to
run the server that that gave you? (It doesn’t look like radrails allows
one to create a
server script without specifying a project, but you never know…)

For a sanity check, open a terminal window and try running
“script/server” from the root
of your project. If it runs just fine, then there’s a problem with
radrails. If so, you
might make a back-up copy of your work and delete/recreate the project
in radrails.

b


#3

I imported the project and did ‘create new server’ from the Server tab
in
the rails perspective. Clicking the run button, however, does nothing.

it does run fine from the project root. I’m getting ‘can’t execute’
errors
in the Eclipse log, which suggests a permissions issue to me, but I
checked
the permissions and they seem ok. rwx for user, group and other. Does
Eclipse do anything strange regarding what user it runs as?
Unfortunately i
just moved to OSX from windows and my understanding of the OS is
shallow.

I’m having similar issues in the Ruby perspective as well.