Radrails doesn't create files via Eclipse


#1

I can’t get Eclipse to create the files for a new Rails project in
Eclipse. It works using the terminal. What could be wrong?


#2

Pål Bergström wrote:

I can’t get Eclipse to create the files for a new Rails project in
Eclipse. It works using the terminal. What could be wrong?

have you set up your Ruby interpreter in Window | Preferences | Ruby ?

Kristof


#3

Kristof Jozsa wrote:

Pål Bergström wrote:

I can’t get Eclipse to create the files for a new Rails project in
Eclipse. It works using the terminal. What could be wrong?

have you set up your Ruby interpreter in Window | Preferences | Ruby ?

Kristof

I tried that, but maybe I didn’t do it right. Does “/usr/local/bin/ruby”
sounds right? And maybe I should restart Eclipse?


#4

Pål Bergström wrote:

Kristof Jozsa wrote:

Pål Bergström wrote:

I can’t get Eclipse to create the files for a new Rails project in
Eclipse. It works using the terminal. What could be wrong?

have you set up your Ruby interpreter in Window | Preferences | Ruby ?

Kristof

I tried that, but maybe I didn’t do it right. Does “/usr/local/bin/ruby”
sounds right? And maybe I should restart Eclipse?

That didn’t work. Perhaps I should run a fix of permissions.


#5

Guest wrote:

That didn’t work. Perhaps I should run a fix of permissions.

I think it’s a bug:
http://dev.radrails.org/trac/ticket/917

I see. So Radrails doesn’t work at all?


#6

Pål Bergström wrote:

In my experience radrails likes you to use: “rails my_app” from the
command line and then you go into radrails, create a rails project and
server, and it picks up the generated app skeleton, but fails to
automatically generate one on its own. That’s my workaround, anyway

Best,
Leo


#7

That didn’t work. Perhaps I should run a fix of permissions.

I think it’s a bug:
http://dev.radrails.org/trac/ticket/917