Radrails config


#1

Bonjour,

J’utilise RoR depuis peu et tout fonctionne merveilleusement.

J’ai téléchargé RadRails qui fonctionne directement sans installation
mais
me pose quelques problèmes:

  1. l’interpréteur ruby ne fonctionne pas dans radrails et j’obtiens ce
    message
  1. le serveur dans radrails ne veut pas se lancer

J’ai bien paramétré
Ruby Ri/rdoc
…\src\ruby-1.8.4\bin\rdoc
…\src\ruby-1.8.4\bin\ri
ainsi que
Rails installs
…ruby\bin\

Il y a t-il un dossier spécifique où copier RadRails ?
Qu’est-ce qui cloche?


#2

Bonjour,

  1. l’interpréteur ruby ne fonctionne pas dans radrails et j’obtiens ce
    message

As-tu installé rubypeople ? (http://updatesite.rubypeople.org/release:
il s’installe comme Radrails par Software Updates)

  1. le serveur dans radrails ne veut pas se lancer

J’ai le même souci, donc pas de solution de ma part :wink:

++
Pierre M.


#3

Il y a t-il un dossier spécifique où copier RadRails ?
Qu’est-ce qui cloche?

En faite dans les options de RadRails, il faut lui indiquer le chemin
vers
l’interpréteur Ruby.
Dans la dernière version de du plug-in RadRails, les options concernant
Ruby
ne sont pas sauvegardées chez moi, il faut donc lui indiquer le chemin Ã
chaque démarrage d’Eclipse. Je n’avais pas le problème sur la version
précédente.


#4

Je n’ai pas la réponse mais un conseil pragmatique :

RadRails est génial comme IDE mais comme environnement d’execution (de
mon
expérience et d’autres autour de moi) il est pas blindé.

Solution : piloter l’application à la main, à partir d’une bonne vielle
boite DOS et faire un Refresh sur le projet (dans le treeview Radrails)
quand on a modifié l’arborescence (par ex. après un script/generate)

En conclusion (sous Windows en tout cas, ce qui semble être ton cas si
j’en
juge par les “”) :

  • Une boite DOS pour Webrick
  • Une boite DOS script/generate, scaffold et compagnie (j’utilise
    fond
    de couleur différente pour m’y retrouver)
  • Click-droit + Refresh dans RadRails pour syncroniser

Solution bas de gamme mais zero tracas :slight_smile:


#5

Pour le refresh, on peut demander directement à eclipse dans General ->
Workspace -> “Refresh automatically”.

Julien


#6

Par contre c’est vrai que l’interpréteur ruby sélectionné disparaît à
chaque fois que j’éteind eclipse… c’est désagréable.
Je pense qu’ils vont corriger ça rapidement… idéalement il faudrait
vérifier s’il y a un bug ouvert et en ouvrir le si ce n’est pas le cas…

J’ai la 0.6.2 en standalone et je n’ai pas ce problème


#7

philippe lachaise wrote:

Je n’ai pas la réponse mais un conseil pragmatique :

RadRails est génial comme IDE mais comme environnement d’execution (de
mon expérience et d’autres autour de moi) il est pas blindé.

Sous Windows XP, je n’ai plus de problème avec les dernières versions de
l’update-site de radrails.
Le serveur démarre correctement…
Les generateurs (scaffold…) sont ok aussi.

Par contre c’est vrai que l’interpréteur ruby sélectionné disparaît à
chaque fois que j’éteind eclipse… c’est désagréable.
Je pense qu’ils vont corriger ça rapidement… idéalement il faudrait
vérifier s’il y a un bug ouvert et en ouvrir le si ce n’est pas le cas…


Benjamin F.
http://rubyscube.blogspot.com


#8

Ca m’est arrivé de ne plus pouvoir éditer tel ou tel type de source
d’une
version à l’autre de RadRails.

J’ai l’impression qu’Eclipse/RadRails ne récupère pas toujours bien le
Workspace entre certaines versions et que ça a des conséquences
bizarres.

En réimportant mes projets dans un nouveau workspace j’arrivais Ã
repartir
normalement


#9

Bonsoir,

j’utilise Eclipse 3.1.0 et les Ruby Development Tools
0.7.0.601192300PRD, sous OpenBSD 3.8 (Eclipse installé à partir des
packages).
J’utilise RadRails en tant que plugin à Eclipse et non pas en version
“standalone”.

J’ai rencontré un problème avec la version 0.6.2, qui m’affichait une
erreur et ne me permettait pas d’éditer un fichier .rhtml.

Je suis revenu en version 0.6.1 (merci Eclipse !) et tout fonctionne
bien.


Guillaume “Zifro” DESRAT
http://…/
– Aah Jeez…I Wish You Could See This…Lights Coming Up…I’ve
Never Seen A Painting That Captures The Beauty Of The Ocean…I’m
Gonna Make You Rich, Bud Fox…Rich Enough You Can Afford A Girl Like
Darien…This Is Your Wake-Up Call, Pall…Go To Work…DROP IT!!!
(3 Steps Ahead - Drop It)


#10

tout à fait, il faut supprimer le chemin par defaut et indique
l’emplacement de l’executable.

Ruby> Installed Interpreters
ruby.exe

Vincent J. wrote:

Il y a t-il un dossier spécifique où copier RadRails ?
Qu’est-ce qui cloche?

En faite dans les options de RadRails, il faut lui indiquer le chemin
vers
l’interpréteur Ruby.
Dans la dernière version de du plug-in RadRails, les options concernant
Ruby
ne sont pas sauvegardées chez moi, il faut donc lui indiquer le chemin Ã
chaque démarrage d’Eclipse. Je n’avais pas le problème sur la version
précédente.


#11

J’ai rencontré un problème avec la version 0.6.2, qui m’affichait une
erreur et ne me permettait pas d’éditer un fichier .rhtml.

C’est un bug connu d’ERB si j’ai bien compris, regarde si ce n’est pas
celui là :
http://dev.radrails.org/trac/ticket/780

Even pasting this into the RHTML editor gives me an “argument not valid”
error, so it’s gotta be something in the syntax highlighting code.

RHTML, meet your doom:
<death to=“the <%= “RHTML editor” %>”>

Other flavors of doom:
<death to =“the <%= “RHTML editor” %>”>
<death to=“the <%= “RHTML editor” %>” >
< death to=“the <%= “RHTML editor” %>”>
< death to=“the <%= “RHTML editor” %>” >

But these variants do not cause the RHTML editor to make the bad noise:

<death to=“the <% = “RHTML editor” %>”>
<death to “the <%= “RHTML editor” %>”>
death to=“the <%= “RHTML editor” %>”
<death to = “the <%= “RHTML editor” %>”>
<death to= “the <%= “RHTML editor” %>”>
<death to=" the <%= “RHTML editor” %>">
<death to=“the <% “RHTML editor” %>”>
<death to="<%= ““the RHTML editor”” %>>