RadRails 0.6 out


#1

Since RadRails 0.6 is out (see http://www.radrails.org/ ), I have made a
“celebratory illustrated tutorial” on how to use the Eclipse update
function
to do the upgrade from within Eclipse (I found the process a tad
confusing):

http://wiki.awebfactory.com.ar/awebfactory/published/UpdateRadRails

saludos,

Victor K.
awebfactory.com.ar


#2

Hi Victor,

I’ve been using the standalong RadRails. Any particular advantage in
using Eclipse and adding the components? (I don’t do Java). It seems
like a lot of trouble installing into Eclipse vs. just unzipping.

Perhaps you could add a section on this? thanks,

-bakki


#3

Bakki,

I’ve been using Eclipse with RadRails plugin. The only reason I would
ever suggest doing so is if you plan on developing in java, which I
still play in from time to time, or you want to add on other plugins
that are available on the Eclipse platform.

Otherwise, if you are strictly using it to develop in Ruby/Rails I
would suggest RadRails standalone since it is much trimmer.

Dave

David Andrew T.
http://dathompson.blogspot.com

#4

David,

THanks for your input. I think I’ll just stick with Rad Rails
standalone for now.

-bakki


#5

Doesn’t RadRails use eclipse anyway? I wasn’t aware there was a
version that wasn’t built on eclipse (and thus Java).


#6

There’s a RadRails eclipse plugin and a standalone version of RadRails
that is built on
top of a very stripped-down eclipse core (but does not require that you
install eclipse
separately). Yes, it’s all written in Java.

http://www.radrails.org/

b


#7

It doesn’t use an installer; it’s just zipped up. But no, it doesn’t
appear that the
standalone version has eclipse’s update mechanism. Still, you should be
able to just unzip
it over your old radrails. Back up your workspace to be safe though.

I actually switched to using the plugin version mostly because the
standalone version
doesn’t have the eclipse search functions(!!). But I’m also a java dev
so…

Oh, and one annoying glitch with the 0.6 update (to the plugin version):
it deleted all my
server entries on the server tab! I guess I’ll have to move my projects
aside, create them
again to get the server config, and then copy the actual files back into
the project. Sigh.

b


#8

Kenneth, radrails uses eclipse in both cases, but the standlalone build
is
just a stripped done eclipse (RCP: Rich Client Platform = thin eclipse
without Java SDK), while the plugin is a regular eclipse plugin.

What I am wondering is whether the Standalone build also allows to
update as
easily as the plugin version, or whether one needs to download a whole
new
installer for upgrading to a new radrails release.


#9

Victor, thank you for the work!

As a newbie, I got 2 dumb questions for all you experts…

  1. What’s the relationship between RadRails and RDT? (If any, how are
    their version numbers aligned? If none, a description of their
    differences is posted somewhere?)

  2. Can RadRails 0.6 resume breakpoints set in a Rails server? This
    feature doesn’t work for me using RDT 0.7.0 and Eclipse 3.1.2 on Fedora
    Core 4/5-test3.

DD


#10

I just want to say thanks to the developers for their hard work. 0.6
does indeed fix many of the annoying syntax highlighting and code
completion bugs. Looking forward to the 1.0 release. Stick with it,
guys!


#11

Ben, thanks for clarification. It also cleared my server entries on the
server tab, but that is very, very simple and to recreate them. I use
the
plugin version because I need it for Java. But based on tha fact that
you
don’t get search und release update functionality with the standalone
version, I would recommend to anyone to use the plugin based version.


#12

Doug,

As far as I know, RadRails primarily uses RDT for its Ruby Editor and
its Testing Framework. RadRails serves to bring the user interface
into the picture (plus a great deal of back end tie-ins), which
includes menu options, wizards, perspectives, etc.

I’ll pass on the breakpoint question and leave it up to some other
hopeful developer. :wink:

Dave

David Andrew T.
http://dathompson.blogspot.com

#13

My Eclipse cannot see 0.6 while updating via
http://radrails.sourceforge.net/update

Am I the only one?


#14

Thank you, David, for the explanation! As for breakpoints, it seems that
RDT 0.7 is broken for Ruby 1.8.4.

Does anyone know what the following error messages mean?

root@localhost:~# eclipse
Invalid Menu Extension (Path is invalid):
org.radrails.rails.ui.test.Default
Invalid Menu Extension (Path is invalid):
org.radrails.rails.ui.test.Unit
Invalid Menu Extension (Path is invalid):
org.radrails.rails.ui.test.Functional

I got them after installing RadRails 0.61 in Fedora Core 5 Final’s
eclipse (3.1.2, java version 1.4.2). 0.6 and 0.61 do the same on FC5
Test3. What functionalities am I missing? Hope not testing… A fix or
workaround?

TIA!


#15

Did you “search for new features” instead of “search for updates” in
eclipse? That still
gets me confused… don’t know why some updates are new features.

Victor’s got a great tutorial on it here:

http://wiki.awebfactory.com.ar/awebfactory/published/UpdateRadRails

b


#16

RadRails is a very good IDE but there is something annoying (that is
certainly related with Eclipse, not RadRails) : under Linux (KDE), the
navigator and outline panes use very BIG FONTS - I found nowhere in
Preferences/General/Appearance a choice to change them and thus
navigating throught the project is annoying as I need to scroll down and
up very very often…

Anybody found a solution for that ?

Thanks


#17

Has anybody experimented with compiling RadRails with GCJ?
http://gcc.gnu.org/java/
It would make it screaming fast…


#18

Oh, feels like the new version is always a “new feature”, not an update
:frowning:


#19

Since the upgrade to 0.6.1 on windows-standalone radrails has completely
crapped out on me. I can only click on things for maybe a minute and
then the cursor locks, the same thing happens with the keyboard while
typing. i can move the cursor around for a while but then out of nowhere
i can’t click on anything or type. if i switch to another application
(alt-tab) and then switch back to radrails i can regain use of the mouse
and keyboard for a little while until it all happens again. this update
has rendered radrails unusable and i don’t have a copy of an older
version which at least worked. has anyone had similar problems? this
isn’t any issue with my laptop since all other programs work fine.


#20

My co-worker tried using GCJ-compiled Eclipse for Java programming and
he said,
ironically, it was nearly un-usable… dog slow! Now, I don’t know how
much he looked into
changing settings or fixing his problem somehow, but… That was the
pre-compiled version
that came with Ubuntu, I believe.

b