Radiant & Pound - changes https to http?


#1

I’m using pound as a reverse proxy for radiant, and although I use https
to connect initially to radiant, after I log in to /admin, all URLs get
changed to regular ‘http’. Is there some way to force radiant to keep
using https URLs?

Here’s an example:

  1. When I go to https://dev.mysite.com/cms, I get our regular content
    site, fine.

  2. When I go to https://dev.mysite.com/cms/admin/login, I can log in
    successfully to radiant’s admin interface, fine.

  3. If I point to any one of the content pages I want to edit, like our
    “About Us” page at /cms/admin/pages/edit/6, the URL is will take me to
    is http://dev.mysite.com/cms/admin/pages/edit/6 (NOT https).

Is there a setting or some other means of fixing this? If it helps, this
is the relevant portion of our pound.cfg:

Service
HeadRequire “Host: .dev.mysite.com.
HeadRequire “Authorization: Basic ."
URL ".
/cms.*”

BackEnd
    Address 192.168.2.33
    Port   3030
  End
End

Any help is much appreciated.

Thanks!
-Jason


#2

Radiant is Rails based here are a couple articles on SSL redirects and
Rails…

http://www.busyashell.com/blog/articles/2006/10/20/how-to-force-https-without-a-host-in-rails
http://blog.innerewut.de/articles/2006/06/21/mongrel-and-rails-behind-apache-2-2-and-ssl