Radiant on bluehost error - undefined method `downcase' for

Hello,
I am new to Ruby (seems to be a common starting line) and I am having
a problem running Radiant.
I am using Bluehost and have installed and ran the sample app that
Bluehost
uses for Ruby. Then I installed Radiant - all went well until I tried to
run Radiant. Error 500 and the production log file shows the below.
All of the permissions are correct
I have tried all of the .htaccess changes,
enviornment file changes from all of the other posts - but still get the
same
error as below.

After I make changes, will they be in effect if I don’t restart apache
or restart something else that I don’t have access to?

Has anyone ever gotten Radiant to run in Bluehost?

Thanks

Logfile created on Wed Mar 05 18:56:37 -0700 2008 by /

Migrating to CreateRadiantTables (1)
Migrating to InsertInitialData (2)
Migrating to RenameBehaviorColumn (3)
Migrating to RenameFilterColumn (4)
Migrating to AddVirtualColumnToPage (5)
Migrating to IntegerColumnsToBoolean (6)
Migrating to RemoveVirtualColumnFromPage (7)
Migrating to AddVirtualColumnToPageAgain (8)
Migrating to AddContentTypeFieldToLayout (9)
Migrating to MergeBehaviorsAndPages (10)
Migrating to RenameTypeColumnOnPageToClassName (11)
Migrating to CreateExtensionMeta (12)
Migrating to AddNotesFieldToUser (13)
Migrating to RenameConfigDefaultPartsKey (14)
Migrating to AddOptimisticLocking (15)
Migrating to AddSessions (16)
undefined method downcase' for nil:NilClass /home/afewtips/.gems/gems/radiant-0.6.4/vendor/rails/actionpack/lib/action_controller/request.rb:22:inmethod’
/home/afewtips/.gems/gems/radiant-0.6.4/vendor/rails/actionpack/lib/action_controller/routing.rb:1366:in
extract_request_environment' /home/afewtips/.gems/gems/radiant-0.6.4/vendor/rails/actionpack/lib/action_controller/routing.rb:1315:inrecognize’
/home/afewtips/.gems/gems/radiant-0.6.4/vendor/rails/railties/lib/dispatcher.rb:40:in
dispatch' /home/afewtips/.gems/gems/radiant-0.6.4/vendor/rails/railties/lib/fcgi_handler.rb:168:inprocess_request’
/home/afewtips/.gems/gems/radiant-0.6.4/vendor/rails/railties/lib/fcgi_handler.rb:143:in
process_each_request!' /home/afewtips/.gems/gems/radiant-0.6.4/vendor/rails/railties/lib/fcgi_handler.rb:109:inwith_signal_handler’
/home/afewtips/.gems/gems/radiant-0.6.4/vendor/rails/railties/lib/fcgi_handler.rb:142:in
process_each_request!' /usr/lib/ruby/gems/1.8/gems/fcgi-0.8.7/lib/fcgi.rb:606:ineach_cgi’
/home/afewtips/.gems/gems/radiant-0.6.4/vendor/rails/railties/lib/fcgi_handler.rb:141:in
process_each_request!' /home/afewtips/.gems/gems/radiant-0.6.4/vendor/rails/railties/lib/fcgi_handler.rb:55:inprocess!’
/home/afewtips/.gems/gems/radiant-0.6.4/vendor/rails/railties/lib/fcgi_handler.rb:25:in
`process!’
./dispatch.fcgi:25

Hello Michael,

The problem may be with the data.

If I type in the Ruby command
puts “A”.downcase
it correctly displays the lower case a.

If I type the Ruby command
puts nil.downcase
I receive the errors you state above, namely,
undefined method `downcase’ for nil:NilClass (NoMethodError)

I suggest you check your data to ensure the thing your trying to
downcase isn’t nil.
Example:
str = nil
puts str.downcase unless str == nil

That said, I know that when installing Perl modules on BlueHost I had to
modify the path to get the application to know where to find not only
the standard BlueHost perl modules but also the special perl modules I
installed. BlueHost has a handy-dandy way of doing this, described on
the cPanel in the Perl section. They don’t have this (yet) for
Ruby/Rails, but I would seriously look at the path.

When you installed Ruby and Rails, did you follow the BlueHost sample at
http://helpdesk.bluehost.com/kb/index.php?x=&mod_id=2&id=232
The path in the example looks like it has a different structure than the
path in your error messages.

The BlueHost forums are great for looking up solutions to problems like
this. It looks like at least one other person has installed Radiant on
BlueHost.
http://bluehostforums.com/showthread.php?t=3398&highlight=radiant

Good luck,

Terri

Thanks very much for the reply and your thoughts on the error.
I have put the hope of Ruby on Bluehost away and if i decide to pursue
Ruby more (and if I find the time I want to) I will do it on SliceHost.

Thanks again.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs