Radiant: MySQL Error


#1

Hi All,

Posted this error earlier - have attached the error and the log below.
Please give me a shout if you have any ideas?

Thanks,
Keith

ActiveRecord::StatementInvalid in SiteController#show_page

Mysql::Error: Lost connection to MySQL server during query: SHOW FIELDS
FROM
config

070218 18:35:35 InnoDB: Started; log sequence number 0 56135
070218 18:35:35 [Warning] mysql.user table is not updated to new
password
format; Disabling new password usage until mysql_fix_privilege_tables is
run
070218 18:35:35 [Warning] Can’t open and lock time zone table: Table
‘mysql.time_zone_leap_second’ doesn’t exist trying to live without them
C:\INSTAN~1\MySql\bin\mysqld.exe: ready for connections.
Version: ‘4.1.9-max’ socket: ‘’ port: 3306 Source distribution


#2

Hi Keith,

no doubt - a real annoying bug.
I found two solutions on the web.

First, by ‘Insane_Edna’ in the rails forum:
Copy libmysql.dll from mysql\bin to ruby\bin
(don’t know whether that works on linux / os x the same way with the
mysql lib)

I can say it worked for me (Win XP) for one project and failed on
radiant.

Second, works on all platforms but it’s definitly NOT best practice

Generate a mysql account with a user without password and update your
database.yml
with it.
Solution 2 always worked fine but I’m not gonna use it in the production
environment.

Hope that helps for the moment. I think we’re in a growing crowd of
people looking forward for a real solution. (updated mysql bindings or
whatever )

Bye
Josh