Radiant (master with rails 2.1) and Tag extension

Hello,

I tried to install the Tags extension
(http://github.com/jomz/radiant-tags-extension/tree/master/README) with
the Radiant master but I got the following problem :

[13:01][[email protected]:~/NetBeansProjects/myproject(master)]$
rake radiant:extensions:tags:install
(in /Users/vincentp/NetBeansProjects/myproject)
rake aborted!
Dependencies is not a module

(See full trace by running task with --trace)

More infos :

[13:01][[email protected]:~/NetBeansProjects/myproject(master)]$
script/server
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.1.1 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
Exiting
/Users/vincentp/NetBeansProjects/myproject/vendor/extensions/tags/vendor/plugins/has_many_polymorphs/lib/has_many_polymorphs/dependencies.rb:8:
Dependencies is not a module (TypeError)
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:inrequire’
from
/Users/vincentp/NetBeansProjects/myproject/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in
require' from /Users/vincentp/NetBeansProjects/myproject/vendor/rails/activesupport/lib/active_support/dependencies.rb:355:innew_constants_in’
from
/Users/vincentp/NetBeansProjects/myproject/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:in
require' from /Users/vincentp/NetBeansProjects/myproject/vendor/extensions/tags/vendor/plugins/has_many_polymorphs/lib/has_many_polymorphs.rb:24 from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in require' ... 43 levels... from /Users/vincentp/NetBeansProjects/myproject/vendor/rails/activesupport/lib/active_support/dependencies.rb:510:inrequire’
from
/Users/vincentp/NetBeansProjects/myproject/vendor/rails/railties/lib/commands/server.rb:39
from script/server:3:in `require’
from script/server:3

Could it come from rails 2.1?

Thanks,
Vincent

Vincent,

My apologies – master is very unstable now because of some major
refactoring going on. I hope to complete some of it this weekend.
You’re best off using 0.6.9 or a head just before the merge with the
Rails 2.1 branch. Andrew vonderLuft recently ran into this problem and
mentioned which commit he chose on the mailing list.

Sean

Acutally,
This is a problem with has_many_polymorphs on newer rails versions.
I’ve received a pull request to fix it but haven’t had time to test it
out. I’ll try to do that today.

-Jim

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs