Radiant could not be initialized. Please verify that vendor/radiant contains a complete copy of the

hi i am working on configuring existing application on locally as well
as
server but i got an error
i use radaint 0.8.2, rails 2.3.4, ruby 1.8.7 and rubygems 1.4.2.

script/server -e production -p 3001
Radiant could not be initialized. Please verify that vendor/radiant
contains a complete copy of the Radiant sources.
is there above explained version is dependable? i use according to app.
or
any dependent gem is needed?
i already install cucumber.
and i tried to re-install also.

please help me

thank you in advance

On Tuesday, 16 October 2012 03:23:00 UTC-4, Nirav wrote:

i already install cucumber.
and i tried to re-install also.

please help me

This is a totally wild guess, but is there a .gitmodules file in your
project root? The symptoms you’ve described sound like there might be a
submodule set up for vendor/radiant, and if it wasn’t initialized then
all
the files would be missing.

–Matt J.

Hi Jones,

Thanx for the reply,

There is no .gitmodules file in root. is there compulsory to be in root
application? because application runs locally fine but there is an issue
for ec2 server.
please give me guide jones.

Thanking You,
Nirav

Hi Jones,

Here are give directory of vendor/radiant

/app
/features
/lib
/public
/spec
/vendor
/bin
/config
/db
/script
/test
CHANGELOG
CONTRIBUTORS
README
INSTALL
LICENSE
radiant.gemspec
Rakefile

Thanking You
Nirav

i have re-install rails, ruby, rubygems and radiant. is it any idea for
this error to anyone what to do after that? i am confused for that.
because
same configuration is there for locally and its work fine. but for ec2
server it gets error. anyone knows about this error? i am stuck at that
error. please give me reply asap.

Thanking You,
Nirav Acharya

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs