Qtruby and Qwt


#1

I am trying to set up a “live” plotting in my Qtruby application (see
my earlier post), and it seems that the Qwt library might be what I am
looking for. As I understand it, Qtruby supports Qwt, but I can’t find
much documentation about it. Is there anybody out there with a simple
example of plotting with Qwt in Ruby?

/Fredrik


#2

I am trying to set up a “live” plotting in my Qtruby application (see
my earlier post), and it seems that the Qwt library might be what I am
looking for. As I understand it, Qtruby supports Qwt, but I can’t find
much documentation about it. Is there anybody out there with a simple
example of plotting with Qwt in Ruby?

It’s not documented greatly, unfortunately, but it should work. Your
past posts
indicate you seem to be using QtRuby for Qt3. Is that right? I think
that the Qwt
support in QtRuby is only for the Qt4 library version (and corresponding
Qwt version

  • 5.x).

Caleb


#3

Caleb T. wrote:

I am trying to set up a “live” plotting in my Qtruby application (see
my earlier post), and it seems that the Qwt library might be what I am
looking for. As I understand it, Qtruby supports Qwt, but I can’t find
much documentation about it. Is there anybody out there with a simple
example of plotting with Qwt in Ruby?

It’s not documented greatly, unfortunately, but it should work. Your past posts
indicate you seem to be using QtRuby for Qt3. Is that right? I think that the Qwt
support in QtRuby is only for the Qt4 library version (and corresponding Qwt version

  • 5.x).
    No, it does work with Qt3 QtRuby too. I had some problems with parsing
    Qt properties in the Qt4 version of Qwt, but I did get that one working
    in the end. For both Qt3 and Qt4, you need to install the Qwt headers
    into the same include directory as the Qt ones, and configure QtRuby
    with ‘–enable-qwt=yes’ to build with the qwt libs.

– Richard


#4

removed_email_address@domain.invalid wrote:

No, it does work with Qt3 QtRuby too. I had some problems with parsing
Qt properties in the Qt4 version of Qwt, but I did get that one working
in the end. For both Qt3 and Qt4, you need to install the Qwt headers
into the same include directory as the Qt ones, and configure QtRuby
with ‘–enable-qwt=yes’ to build with the qwt libs.

– Richard

Are you sure about that? In qtruby-1.0.13 I configure with this:
./configure --with-smoke=“qt” --with-qt-dir=/usr/local/qt
–enable-qwt=yes --prefix=/usr
but I cannot see that configure is doing anything about that. Anyway, I
complete the installation and try
$ irb

require ‘Qwt’
LoadError: no such file to load – Qwt
and I guess that means it was not installed?

/Fredrik


#5

Fredrik J wrote:

./configure --with-smoke=“qt” --with-qt-dir=/usr/local/qt
–enable-qwt=yes --prefix=/usr
but I cannot see that configure is doing anything about that. Anyway, I
complete the installation and try
$ irb

require ‘Qwt’
LoadError: no such file to load – Qwt
and I guess that means it was not installed?
Ah bother, Caleb was right - it looks like I never did a Qt3 version. I
remembered getting Qwt to work twice and the second one being a bit
more work. I was thinking of Qwt 4.x vs Qwt 5.x though, and I’ve only
ever got them working with the Qt4 version of QtRuby. Sorry about
wasting your time on that. But I don’t think it would be too hard to
get Qwt working for Qt3 QtRuby though all the same.

– Richard