QT GUI Chooser not working

GRC v3.7.2.1-195-g19d111e2 // ubuntu 13.10

Using QT GUI range works fine, changing it to QT GUI chooser (Type =
Integer)
seems to fail (regardless of number of options), with the following
error message:

linux; GNU C++ version 4.8.1; Boost_105300; UHD_003.006.000-0-g7788c692

Traceback (most recent call last):
File “/home/tom/Desktop/top_block.py”, line 185, in
tb = top_block()
File “/home/tom/Desktop/top_block.py”, line 78, in init
self._RxFreq_callback(self.RxFreq)
File “/home/tom/Desktop/top_block.py”, line 77, in
self._RxFreq_callback = lambda i:
Qt.QMetaObject.invokeMethod(self._RxFreq_button_group,
“updateButtonChecked”, Qt.Q_ARG(“int”, self._RxFreq_options.index(i)))
ValueError: tuple.index(x): x not in tuple

A bug? More information needed?

– Tom, N5EG

On Mon, Feb 24, 2014 at 10:01 PM, Tom McDermott
[email protected] wrote:

A bug? More information needed?

– Tom, N5EG

Just tested this locally, using a integer chooser to change the noise
type of a noise source. Worked fine for me.

My guess is a version difference. I’m running QT 4.8.1 (on Ubuntu
12.04). This also worked for me using QWT 5.2 and 6.1.

Tom

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs