Python-problem

Hi,

I have just installed gnuradio 3.1.1 on a SuSE-linux 10.3

make performed without errors however make check reports:

ERROR: test_blks_import (main.test_head)

Traceback (most recent call last):
File “./qa_kludged_imports.py”, line 35, in test_blks_import
from gnuradio import blks
File
“/scr/gnuradio-3.1.1/gnuradio-core/src/python/gnuradio/blks/init.py”,
line 37, in
exec “from gnuradio.blksimpl.%s import *” % (f,)
File “”, line 1, in
File
“/scr/gnuradio-3.1.1/gnuradio-core/src/python/gnuradio/blksimpl/rational_resampler.py”,
line 22, in
from gnuradio import gr, gru
File
“/scr/gnuradio-3.1.1/gnuradio-core/src/python/gnuradio/gru/init.py”,
line 37, in
exec “from gnuradio.gruimpl.%s import *” % (f,)
File “”, line 1, in
File
“/scr/gnuradio-3.1.1/gnuradio-core/src/python/gnuradio/gruimpl/gnuplot_freqz.py”,
line 28, in
import numpy
ImportError: No module named numpy

I kept the default settings, thus gnuradio got installed in
/usr/local/lib/python2.5/site-packages/ while SuSE seems to put all the
pyhthon-stuff (including Numeric/_numpy.so) into
/usr/lib/python2.5/site-packages.
I thus set setenv PYTHONPATH
/usr/local/lib/python2.5/site-packages/:/usr/lib/python2.5/site-packages
=> no effect.
BTW: I get the same error-message when I try an example like
gnuradio-3.1.1/gnuradio-examples/python/usrp/ usrp_benchmark_usb.py
I try everything as root for the time being.

Any hint on how I can make gnuradio consider both python directories
would
be very welcome

Thanks
Wolfgang

View this message in context:
http://www.nabble.com/python-problem-tp16347380p16347380.html
Sent from the GnuRadio mailing list archive at Nabble.com.

O.k.
I seem to have figured it out myself. In case anybody else might run
into
the same problem:

I installed numpy-1.0.4 from the source. This seems to be required on
SuSE
10.3 eventhough a file
named _numpy.so was present in /usr/lib/python2.5/site-packages/Numeric
beforehand.

I don’t understand why, but for me it fixed the problem.

Regards

 Wolfgang

wolfgang buesser wrote:

File “./qa_kludged_imports.py”, line 35, in test_blks_import
File
I kept the default settings, thus gnuradio got installed in
Any hint on how I can make gnuradio consider both python directories would
be very welcome

Thanks
Wolfgang


View this message in context:
http://www.nabble.com/python-problem-tp16347380p16349804.html
Sent from the GnuRadio mailing list archive at Nabble.com.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs