Hi all,

I am a first time Ubuntu user and I am attempting to get gnuradio to
work with a usrp2. I have tried to use the binary download option. I
have installed 9.04 (jaunty) and I have used the synaptic package
manager to download the right dependancies.

Once I run

$ sudo aptitude install gnuradio gnuradio-companion

It installs ok but when i go to run grc i get the following errors:

cannot import gnuradio. are your PYTHONPATH and LD_LIBRARY_PATH set

Being a completely new linux user I am lost as to what this means/ what
I need to do to fix it.

Any help will be greatly appreciated.


Python needs to know the path to user installed modules. See the very
last section here (which I have quoted below):

You may also need to do a:

export LD_LIBRARY_PATH=/usr/local/lib
sudo ldconfig

I also just got a USRP2 but running under Fedora 14.

The default install path for GNU Radio is /usr/local, but this is not
part of the default Python module search path. The easiest way to that
is to add this to ~/.bashrc or in the personal initialization file for
your favourite shell.
Determine what version of python you are using:

$ python -V
Python 2.5

Then set the PYTHONPATH environment variable to a value that includes
your installation prefix
and the appropriate python version. E.g.,
x86 (32-bit) systems:

export PYTHONPATH=/usr/local/lib/python2.5/site-packages

Thanks for the help.

I set my libraries and i still get the same error. When I set my
LD_LIBRARY path is there supposed to be a file in /usr/local/lib that
correlates to that library?

For example the python path is set to /usr/local/lib/python2.6 and in
that folder are files pertaining to python.

However in the /usr/local/lib there is nothing dedicated to LD_LIBRARY

Do i need to download something else? Or did gnuradio not install