Pybombs install gnuradio failing on gr-fcd

Hello,

I’m trying to install GNU Radio using pybombs on a Debian 6.0/amd64
system and it gets as far as:

[ 93%] Building CXX object
gr-atsc/lib/CMakeFiles/test_atsci.dir/test_atsci.cc.o
Linking CXX executable test_atsci
[ 93%] Built target test_atsci
make: *** [all] Error 2
bash return val = 2
Traceback (most recent call last):

If I then run make -j4 from src/gnuradio/build I get:

[ 87%] Built target gnuradio-atsc
…/…/lib/libgnuradio-fcd-3.7.1git.so.0.0.0: undefined reference to
`libusb_handle_events_completed’
collect2: ld returned 1 exit status
make[2]: *** [gr-fcd/examples/c++/fcd_nfm_rx] Error 1
make[1]: *** [gr-fcd/examples/c++/CMakeFiles/fcd_nfm_rx.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs…
[ 88%] Built target test_atsci
[ 88%] Built target _qtgui_swig
[ 93%] Built target gnuradio-digital
make: *** [all] Error 2

So I tried setting -DENABLE_GR_FCD=OFF in the recipe and running
pybombs install again, but it still fails at the same point, so I
guess it’s not being reconfigured. How would I do this? Alternatively,
any idea what I should do to get gr-fcd to build? libusb-1.0-0-dev is
installed.

Cheers,

Andrew


Andrew B.
http://carrierdetect.com

On Sat, Aug 3, 2013 at 8:52 AM, Andrew B. [email protected]
wrote:

Traceback (most recent call last):
[ 88%] Built target test_atsci
[ 88%] Built target _qtgui_swig
[ 93%] Built target gnuradio-digital
make: *** [all] Error 2

So I tried setting -DENABLE_GR_FCD=OFF in the recipe and running
pybombs install again, but it still fails at the same point, so I
guess it’s not being reconfigured. How would I do this? Alternatively,
any idea what I should do to get gr-fcd to build? libusb-1.0-0-dev is
installed.

There is a rebuild option:
./pybombs rb gnuradio
but I don’t know if it will clean the cache and everything.

You can also just run:
./pybombs uninstall gnuradio
and maybe also
./pybombs clean gnuradio
to start from fresh

Alex