Pybombs difficulty

I use gentoo at home and have no difficulty keeping gnuradio up to date.

At work we’re on a standalone network (no internet) so occasionally
bring
computers home to update them. Lately, I’ve been having trouble with
pybombs. Using a freshly installed ubuntu 15.04, then doing an

apt-get update
apt-get upgrade [not sure the update was necessary]

I first used

apt-get install gnuradio

Thinking better of it, I ran

apt-get remove gnuradio
apt-get autoremove

Then went with pybombs

git clone git://github.com/pybombs/pybombs
cd pybombs
./pybombs config [use install path /usr/local/gnuradio]
./pybombs install gnuradio

And after several tries continue to receive this error:

[…many lines of install…]
Unpacking liblog4cpp5-dev (1.0-4) …
Setting up liblog4cpp5-dev (1.0-4) …
installation ok via: deb
Installing from source: gnuradio
Cloning into ‘gnuradio’…
Checking connectivity… done.
Cloning into ‘volk’…
remote: Counting objects: 5450, done.
remote: Compressing objects: 100% (10/10), done.
remote: Total 5450 (delta 2), reused 0 (delta 0), pack-reused 5440
Receiving objects: 100% (5450/5450), 1.54 MiB | 0 bytes/s, done.
Resolving deltas: 100% (3918/3918), done.
Checking connectivity… done.

CC=gcc CXX=g++ cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo

-DCMAKE_INSTALL_PREFIX=/usr/local/gnuradio -DENABLE_DOXYGEN=OFF

Configuring: (100%)
[==========================================================]
Configuration failed. Re-trying with higher verbosity.
make: *** No targets specified and no makefile found. Stop.
Build failed. See output above for error messages.

Any hints as to what is going wrong?

Thanks,
Mike

Mike,

When I ran into this problem, I had to reinstall pybombs. I think the
problem lies in changing the installation prefix after installing
pybombs.

I’m sure there is another way to fix this, I just don’t know what it is.

When I reinstalled pybombs, I defined the installation prefix when the
several prompts are asked at the beginning.

Sent from my Cyanogen phone

Thanks, Nathan, and all who replied publicly and privately,

The problem seems to be that I had installed Anaconda (from Continuum
Analytics) which does not include Cheetah by default. It does exist,
however, in the python tree installed by ubuntu, and that seemed to
confuse
things. I installed Cheetah within the anaconda tree and I believe all
is
well. I can say for sure when compiling completes!

Thanks for the speedy and helpful replies,
Mike

On Mon, Aug 3, 2015 at 8:38 PM, West, Nathan
[email protected]

Logan,

For your case deleting inventory.dat would do the trick of effectively
resetting pybombs state (and if your done with an install rm the prefix)

Mike,

Pybombs is hiding the true error. Cmake failed for either VOLK or GNU
Radio. Try running pybombs again with -v -v

Thanks Nathan. Should I have to use sudo when using pybomb commands, now
that the installation prefix is outside of my home directory(because I
now
I have to use sudo when using pybomb commands)?

Logan Washbourne
Electrical Engineering Graduate Student
(Electromagnetics)

On Mon, Aug 3, 2015 at 7:38 PM, West, Nathan
[email protected]

You only have to use sudo with pybombs if you don’t have write
permission
to your prefix. In general it’s best to avoid using sudo and pybombs
together if possible (with the exception of when pybombs asks you for
sudo
password when using apt-get install). You can either set the prefix to
somewhere your user normally has write access to (typically your home
directory), or alter permissions of your prefix. As an example, if you
were
setting your prefix to /opt/gnuradio/pybombs-v3.7.8 the least obtrusive
way to do this is
sudo mkdir -p /opt/gnuradio/pybombs-v3.7.8 # assuming your user
doesn’t
have write access to /opt/gnuradio you need sudo to mkdir
sudo chown myusername:mygroupname /opt/gnuradio/pybombs-v3.7.8
./pybombs install gnuradio

In practice I usually make a group on my machines called ‘developer’ and
add my user to it, then give the developer group ownership or write
access
(depends on what I feel like when I set up a new machine) to /opt. That
lets me write whatever to /opt without sudo (don’t forget you need to
login
after adding your user to group for it to take effect). The same
principle
can be used with /usr/local or any other directory, but IMHO you should
at
least make your work an extra layer deep so you can just rm -rf the
whole
prefix (without root!) and not have much to worry about damaging.

Cheers,
Nathan

On Mon, Aug 3, 2015 at 9:15 PM, Washbourne, Logan <

So I changed the install prefix to /home/username/thesis/target and then
deleted the inventory.dat file and removed the previous install prefix
folder(this was usr/local, but it actually ended up in usr/local/share,
I’m
thinking this was a problem because I think there are lingering files).
I’m
having problems now, I can’t remove or update any packages, it states
that
there is not an inventory file so it creates an empty one and then
states
there is nothing to do. Is there a way to have it generate a new
inventory
file? I can’t install any packages because they seem to still be in the
pybombs folder. Do you have any advice Nathan?

My initial reasoning for changing the install prefix to usr/local/ was
to
enable me to create my own OOT modules and build the tutorial examples.
When pybomb’s install prefix was in my home directory it kept throwing
an
error about the CMake files. I tried to change the install prefix
locations
within those CMake files but that didn’t seem to fix my problems.

I’m really starting to learn that a little knowledge can be a pretty
dangerous thing haha.

I appreciate your time and help,

Logan Washbourne
Electrical Engineering Graduate Student
(Electromagnetics)

On Mon, Aug 3, 2015 at 10:06 PM, West, Nathan
[email protected]

Hi Logan,

Here is a full set of commands for installing in your own home directory
via pybombs:

git clone https://github.com/gnuradio/pybombs
cd pybombs
./pybombs config

sudo rm -rf /home/gnuradio
sudo mkdir /home/gnuradio
sudo chown -R linux /home/gnuradio /home/linux/pybombs
rm -rf inventory.dat src
[email protected]:~/pybombs$ ./pybombs install -v -v gnuradio

add gnuradio and all apps you want, then change path to:

source /home/gnuradio/setup_env.sh
[email protected]:~$ sudo gedit .bashrc
[email protected]:~$ source ~/.bashrc

Good luck! :slight_smile:

BR,

Iluta

On Tue, Aug 4, 2015 at 5:25 PM, Washbourne, Logan <

Thanks Iluta and Nathan,

My problem was not being able to use the gr-tutorials examples if I
didn’t
have Gnuradio installed in /usr/local, but then I realized that the
gr-tutorials was also a pybombs recipe so I used pybombs to install it
and
everything worked out great! Thank you both for helping me learn how to
move my install prefix around and about proper folder locations.

Logan Washbourne
Electrical Engineering Graduate Student
(Electromagnetics)

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs