Prototype 1.5.0_rc0 breaks my Form.serialize


#1

Cheers,

Prototype 1.5.0_rc0 breaks backwards compatability with this diff in
Form.Element.Serializers:

http://dev.rubyonrails.org/changeset/4147

I have explicit value="" in my options and now I get the text submitted.
E.g.

Please select a value Nr. 1 Nr. 1

Now I get foo=‘Please select a value’ against foo=’’ with prototype 1.4.

This breaks my code.

Jonathan


#2

Bob H. wrote:

You might try fixing the tags that are likely intended to be

. Don't know how far that'll get you but it might make things a bit clearer.

Sorry for this, this was just a copy&paste error. This has nothing to do
with my real problem.

The real code of course has blabla

Cheers,
Bob

Regards,
Jonathan


#3

On Apr 7, 2006, at 8:14 AM, Jonathan W. wrote:

submitted.
E.g.

Please select a value Nr. 1 Nr. 1

You might try fixing the tags that are likely intended to
be . Don’t know how far that’ll get you but it might make
things a bit clearer.

Cheers,
Bob

Jonathan W.
http://blog.innerewut.de


Rails mailing list
removed_email_address@domain.invalid
http://lists.rubyonrails.org/mailman/listinfo/rails


Bob H. – blogs at <http://www.recursive.ca/
hutch/>
Recursive Design Inc. – http://www.recursive.ca/
Raconteur – http://www.raconteur.info/
xampl for Ruby – http://rubyforge.org/projects/xampl/