Proper Installation on Debian?

So I have been trying to follow the instructions on
http://www.debian-administration.org/articles/329 to get rails to be
running properly on my Debian machine, but I have been running into
several issues. The first one just being the version of RubyGems in the
Debian repos doesn’t seem to work while it does if I just install from
the tarball downloaded right from the RubyGems site. However, now I
have a different issue.

I am just trying to get WEBrick running so I can test this demo app and
I get errors spewed at me. I’ll paste the errors below. I am just
wondering if it is possible that WEBrick and Apache are fighting for
port use and how I should change my configuration to make everything
work correctly, even if it means abandoning WEBrick and using only
Apache.

PS: I am also using Apache2 so even though I said I was following the
guide I posted the link to, I used all package names with apache2
instead of apache.

Error Paste:

[email protected]:/var/rails/demo# ruby script/server
=> Booting WEBrick
=> Rails 2.3.5 application starting on http://0.0.0.0:3000
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:271:in
require_frameworks': no such file to load -- net/https (RuntimeError) from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:134:inprocess’
from
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in send' from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:inrun’
from /var/rails/demo/config/environment.rb:9
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:innew_constants_in’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
require' from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/commands/server.rb:84 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require’
from script/server:3

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs