.profile y RMagic

Buenos dias a la lista. Estoy intentando instalar todo lo necesario para
hacer funcionar RMagic[1] con Attactmet_fu[2] en un Mac OS X 10.4 tiger
Para porder funcionar con RMagic, primero necesito tener un procesador
de
imagenes. En mi caso imageMagic[3].
Hasta aqui bien, para instalar ImageMagic de forma “fácil” me decidí por
instalarme MacPorts [4]. Vale lo instalo y funciona y le digo:

[[sudo port install imageMagic]]

Le cuesta un montón pero me lo instala. compruebo que lo tengo instalado
[5]

MI PROBLEMA:
El siguiente paso despues de instalar imageMagic es instalar RMagic (que
es
la union de Ruby con imageMagic, el procesador de imagenes, el que las
corta, redimensiona,…creo)
Yo super feliz digo, esto que viene es facil, sólo es una gema, le digo

[sudo gem install rmagick]

Para mi sorpresa, el terminal me suelta:

[[sudo: gem: command not found]]

QUE ME PUEDE PASAR:
En [4] se dice que El binario de macPorts al instalarse, crea un archivo
.profile en la raiz de mi usuario. Lo puedo ver si en el terminal le
digo
[ls -a]
Ahora esto es lo que hay en mi .profile:

_____----------------------------- ________
export PATH="/usr/local/bin:/usr/local/sbin:/usr/local/mysql/bin:$PATH"

Your previous .profile (if any) is saved as .profile.mpsaved

Setting the path for MacPorts.

export PATH=/opt/local/bin:/opt/local/sbin:$PATH
export DISPLAY=:0.0
export EDITOR=/usr/bin/pico

_______ ---------------------------________________

Aparte hay dos archivos más que he tocado:
.bash_profile
_____----------------------------- _____________

export PATH=$PATH:/opt/local/bin
export MANPATH=$MANPATH:/opt/local/share/man
export INFOPATH=$INFOPATH:/opt/local/share/info
_____----------------------------- ________

.bash_login ----> Vacio

y ya no puedo aportar más información. No sé que puedo haber hecho para
que
el comando [gem] no me funcione cuando siempre me ha funcionado
La he liado bien :frowning:

Manuel: “Espero que este tema no sea demasiado offtopic.”

[1] http://rmagick.rubyforge.org/install-osx.html
[2] http://www.railsforum.com/viewtopic.php?pid=60803
[3] http://www.imagemagick.org/script/binary-releases.php#macosx
[4] http://trac.macosforge.org/projects/macports/wiki/InstallingMacPorts
[5] Para instalar MacPorts en Mac OS X necesitas tener instalado X11,
X11SDK
y Xcode. Esto está muy bien explicado en [4]

On Apr 29, 2008, at 10:34 , Andrés gutiérrez wrote:

Buenos dias a la lista. Estoy intentando instalar todo lo necesario
para hacer funcionar RMagic[1] con Attactmet_fu[2] en un Mac OS X
10.4 tiger
Para porder funcionar con RMagic, primero necesito tener un
procesador de imagenes. En mi caso imageMagic[3].
Hasta aqui bien, para instalar ImageMagic de forma “fácil” me decidí
por instalarme MacPorts [4].

Por si no avanzaras por ahi, en la pagina de descargas de RMagick hay
un script shell que descarga todo, dependencias incluidas, y compila
todo. Es darle y esperar.

On Apr 29, 2008, at 10:37 , Xavier N. wrote:

Por si no avanzaras por ahi, en la pagina de descargas de RMagick
hay un script shell

Errrr no, es un script Ruby.

Yo no veo ningún problema con los profiles… porque no pruebas una
busqueda
de gem “a piñón”?
find / -name gem -type f
Puedes buscar desde / en adelante archivos que contengan “gem” y sean
ficheros estandard “type f”

2008/4/29 Andrés gutiérrez [email protected]:

Yo no veo ningún problema con los profiles… porque no pruebas una
busqueda de gem “a piñón”?

find / -name gem -type f
Puedes buscar desde / en adelante archivos que contengan “gem” y sean
ficheros estandard “type f”

vale estoy haciendo la busqueda en el terminal y ahora la mustro. aunque
no
comprendo el motivo.

El día 29 de abril de 2008 10:42, Dani D. [email protected]
escribió:

http://aaronvanderzwan.com/blog/?p=108

En Google Rmagick for Mac te saca un porrón de páginas con scripts y
cosillas chulas.

Saludos.

PD. Esos scripts funcionan también de maravilla en Ubuntu, en otras
distros no probé.

¿Cómo instalaste Rubygems/Ruby en un principio? ¿Desde los fuentes?
¿Desde MacPorts? ¿Otro?

En el caso de que instalases desde fuentes y no cambiases nada gem
debería estar en /usr/local/bin, con MacPorts debería estar en
/opt/local/bin (claro que este debería estar en el PATH).

Por cierto, supongo que es tontería, pero los cambios en el .profile
no se recargan hasta que abres una nueva sesión de Terminal.

Suerte.

http://aaronvanderzwan.com/blog/?p=108http://aaronvanderzwan.com/blog/?p=108

En Google Rmagick for Mac te saca un porrón de páginas con scripts y
cosillas chulas.

Que bien me hubiera venido esto ayer, pero mi problema hoy es que ya
teno
instalado MacPorts (cosa que me gusta) e imageMagic. Solo me queda
instalar
la gema Rmagic, pero no me funciona el comando [gem] Osea que lo que
pido es
si alguien me puede orientar para indicarme en que la he cagado

El día 29 de abril de 2008 10:40, Pablo Formoso E. <
[email protected]> escribió:

La busqueda que te he pasado antes es para ver si aún tienes gem dando
vueltas por el sistema pero está fuera del path.

Vale aqui esta la busqueda [1], que es lo que he hecho mal? por que no
encuentra el comando gem?
Estoy seguro que es un tema de PATH, pero no se como arreglarlo

[1] http://pastie.caboo.se/188570

El día 29 de abril de 2008 10:58, Dani D. [email protected]
escribió:

Veo vários:

/Applications/RubyNetBeans.app/Contents/Resources/nbrubyide/ruby1/jruby-1.0.1/bin/gem
/usr/local/bin/gem
/usr/local/lib/ruby/gems/1.8/gems/rubygems-update-1.0.1/bin/gem
/usr/local/src/rubygems-0.9.2/bin/gem

si ejecutas “/usr/local/bin/gem --help” debe funcionar

$ echo $PATH

debe darte el path efectivo.

NOTA: No se a partir de que nivel esto es offtopic y debe ser
reconducido en
privado :))

2008/4/29 Andrés gutiérrez [email protected]:

Creo que he visto tu problema.

En tu .profile, la primera línea hace un export PATH y luego un valor
entrecomillado, quitale las comillas, no son necesarias (y después al
volver a utilizar $PATH en el otro export creo que te fastidian).

Suerte.

La busqueda que te he pasado antes es para ver si aún tienes gem dando
vueltas por el sistema pero está fuera del path.

2008/4/29 Andrés gutiérrez [email protected]:

¿Cómo instalaste Rubygems/Ruby en un principio? ¿Desde los fuentes?
¿Desde MacPorts? ¿Otro?

En el caso de que instalases desde fuentes y no cambiases nada gem
debería estar en /usr/local/bin, con MacPorts debería estar en
/opt/local/bin (claro que este debería estar en el PATH).

Desde fuentes, ya que las gem lo tengo desde hace un año y MacPorts lo
instale ayer para instalar ImageMagic
Esto es lo que tengo en el directorio que me has dicho

/usr/local/bin yo$ ls -a
. gem_mirror rails
svnadmin
… gem_server rake
svndumpfilter
.DS_Store gemlock rb-keygen
svnlook
apr-config gemri rdebug
svnserve
apu-config gemwhich rdoc
svnsync
cap gpgen ri
svnversion
capify index_gem_repository.rb ruby
techbook
erb inline_package rubyforge
testrb
fontforge irb sfddiff
update_rubygems
fontimage mongrel_rails sow
gem neon-config svn

El día 29 de abril de 2008 11:04, Andrés gutiérrez
[email protected]
escribió:

perdon es asi como me queda el archivo [.profile]

export PATH=/usr/local/bin:/usr/local/sbin:/usr/local/mysql/bin:$PATH

Your previous .profile (if any) is saved as .profile.mpsaved

Setting the path for MacPorts.

export PATH=/opt/local/bin:/opt/local/sbin:$PATH
export DISPLAY=:0.0
export EDITOR=/usr/bin/pico

2008/4/29 Andrés gutiérrez [email protected]:

Creo que he visto tu problema.

En tu .profile, la primera línea hace un export PATH y luego un valor
entrecomillado, quitale las comillas, no son necesarias (y después al
volver a utilizar $PATH en el otro export creo que te fastidian).
export PATH=/usr/local/bin:/usr/local/sbin:/usr/local/mysql/bin:$PATH

vamos por partes, primero daniel, le he quitado las comillas que
comentas, y
esto es lo que me queda en [.profile]

Your previous .profile (if any) is saved as .profile.mpsaved

Setting the path for MacPorts.

export PATH=/opt/local/bin:/opt/local/sbin:$PATH
export DISPLAY=:0.0
export EDITOR=/usr/bin/pico

No me funciona, hago gem
y me dice: -bash: gem: command not found

2008/4/29 Daniel R. Troitiño [email protected]:

Vale, ahora Dani:

/Applications/RubyNetBeans.app
/Contents/Resources/nbrubyide/ruby1/jruby-1.0.1/bin/gem
/usr/local/bin/gem
/usr/local/lib/ruby/gems/1.8/gems/rubygems-update-1.0.1/bin/gem
/usr/local/src/rubygems-0.9.2/bin/gem

si ejecutas “/usr/local/bin/gem --help” debe funcionar

$ echo $PATH

debe darte el path efectivo.

Me lo da!!! [/bin:/sbin:/usr/bin:/usr/sbin]ahora que hago con este
PATH??
donde lo pongo???

El día 29 de abril de 2008 11:20, Andrés gutiérrez
[email protected]
escribió:

Vamos a ser un poco paranoicos y reduce los dos export PATH a uno, en tu
profile combinalos quedando así

export
PATH=/usr/local/bin:/usr/local/sbin:/usr/local/mysql/bin:/opt/local/bin:/opt/local/sbin:$PATH

recarga la consola con

$ exec bash --login

vuelca a la salida el contenido de $PATH

$ echo $PATH

Ahora debe aparecer /usr/local/bin

$ which gem

debe decirte que está en /usr/local/bin/gem. Y

$ gem --help

debe funcionar.

2008/4/29 Andrés gutiérrez [email protected]:

Haz lo que recomienda Dani D., un “echo $PATH”, porque
/usr/local/bin parece estar en el PATH.

2008/4/29 Andrés gutiérrez [email protected]:

Me lo da!!! [/bin:/sbin:/usr/bin:/usr/sbin]ahora que hago con este PATH??
donde lo pongo???

Genial, no hace falta que lo pongas en ningún sitio porque ya lo tienes
configurado en el .profile

ahora gem al estar en el PATH es accesible sin escribirle la ruta
completa

$ gem --help
debe funcionar, y

$ sudo gem install rmagick
tambien debe funcionar

Venga, nos vemos

Vamos a ser un poco paranoicos y reduce los dos export PATH a uno, en tu
profile combinalos quedando así

export PATH=/usr/local/bin:/usr/local
/sbin:/usr/local/mysql/bin:/opt/local/bin:/opt/local/sbin:$PATH

recarga la consola con

$ exec bash --login

vuelca a la salida el contenido de $PATH

$ echo $PATH

Ahora debe aparecer /usr/local/bin

$ which gem

debe decirte que está en /usr/local/bin/gem. Y

$ gem --help

Lo siento por ser tan coñazo. pero creo que estamos cerca!!! El PATH que
me
dice dani no me funciona. Esto es lo que tengo en mi [.profile]

export
PATH=/usr/local/bin:/usr/local/sbin:/usr/local/mysql/bin:/opt/local/bin:/opt/local/sbin:$PATH

Your previous .profile (if any) is saved as .profile.mpsaved

Setting the path for MacPorts.

export PATH=/opt/local/bin:/opt/local/sbin:$PATH
export DISPLAY=:0.0
export EDITOR=/usr/bin/pico

El día 29 de abril de 2008 11:43, Dani D. [email protected]
escribió:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs