Problems with upgrade to 1.8.4

Actually this is almost a gems problem in that it shows up with gems.

I’ve installed a new compile of 1.8.4 and rubygems 0.9.0
However when I try to run gems it can’t find a library file:

$ gem
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require': no such file to load -- zlib (LoadError) from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from /usr/lib/ruby/site_ruby/1.8/rubygems/package.rb:9
from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' from /usr/lib/ruby/site_ruby/1.8/rubygems/builder.rb:7 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:93:in `manage_gems’
from /usr/bin/gem:10

“zlib” ?? as in “zlib.rb” or …

$ find /usr/lib/ruby -name ‘zlib’ -print
/usr/lib/ruby/1.8/i586-linux-gnu/zlib.so

There seem to be a few other things it can’t find like ‘path.rb’

Were these supposed to be in the Ruby distribution or do I need to
download
them from somewhere else?

On 10/13/06, Anton A. [email protected] wrote:

    from /usr/lib/ruby/site_ruby/1.8/rubygems/package.rb:9

$ find /usr/lib/ruby -name ‘zlib’ -print
/usr/lib/ruby/1.8/i586-linux-gnu/zlib.so

There seem to be a few other things it can’t find like ‘path.rb’

Were these supposed to be in the Ruby distribution or do I need to download
them from somewhere else?

What Linux distro is this? Sounds like you don’t have zlib installed.
(The presence of zlib.so in Ruby’s lib directories does not indicate
that the ‘real’ zlib is available on your system.)

If this is Debian, they have chosen to give zlib the insane name of
zlib1g-dev.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs