Problems with themes in rails 1.2.1 -> named_route

i saw someone mentioned this somewhere else (1), but i wanted to make
sure that this wasn’t something that was going to cause me alot of grief
later…

i have been using the theme plugin (2) on several projects…

i updated to 1.2.1 today, and upgraded my mongrel to the latest one…

when i try running mongrel after updating my project, i get the
following error:

/Users/xxxx/Sites/theres_this_place/config/…/vendor/plugins/theme_support/lib/patches/routeset_ex.rb:26:in
create_theme_routes': undefined methodnamed_route’ for
#ActionController::Routing::RouteSet:0x14d5c18 (NoMethodError)

which is actually alot longer (3)…

is there something i need to to to get named_route working?

the fix mentioned in (2) does work, but i wanted to see if there was a
more permanent solution yet…

thanks all!

(1) http://www.ruby-forum.com/topic/92235#183880
(2)
http://www.mattmccray.com/archive/2005/10/26/Full_Theme_Support_in_Rails_Re

(3)
/Users/xxxx/Sites/theres_this_place/config/…/vendor/plugins/theme_support/lib/patches/routeset_ex.rb:26:in
create_theme_routes': undefined methodnamed_route’ for
#ActionController::Routing::RouteSet:0x14d5c18 (NoMethodError)
from
/Users/xxxx/Sites/theres_this_place/config/…/vendor/plugins/theme_support/lib/patches/routeset_ex.rb:13:in
draw' from /Users/xxxx/Sites/theres_this_place/config/../config/routes.rb:1 from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:489:inload’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:343:in
new_constants_in' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:489:inload’
from
/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.13.1/lib/action_controller/routing.rb:1154:in
load_routes!' from /usr/local/lib/ruby/gems/1.8/gems/actionpack-1.13.1/lib/action_controller/routing.rb:1146:inreload’
from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/initializer.rb:287:in
initialize_routing' ... 9 levels... from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails:83:inrun’
from
/usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/command.rb:211:in
`run’
from
/usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails:243
from /usr/local/bin/mongrel_rails:18

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs