Problems with Ruby on Windows + devkit + bundler + multiple drives

I’m having a strange issue with this combination of ruby on Windows,
with the devkit, bundler, and trying to get a gem to build native
extensions when installed to a vendor/bundle folder on a different drive
than ruby.

The Gemfile I’m using is simple:
source ‘https://rubygems.org/
gem ‘puma’, ‘1.6.3’

And here’s the commands I’m running:

d:\test>bundle install --path vendor/bundle
Fetching gem metadata from https://rubygems.org/
Resolving dependencies…
Installing rack (1.5.2)
Installing puma (1.6.3)
Using bundler (1.3.5)
Your bundle is complete!
It was installed into ./vendor/bundle

d:\test>bundle exec ruby -e “require ‘puma’”
D:/test/vendor/bundle/ruby/1.9.1/gems/puma-1.6.3/lib/puma/server.rb:12:in
require': cannot load such file -- puma/puma_http11 (LoadError) from D:/test/vendor/bundle/ruby/1.9.1/gems/puma-1.6.3/lib/puma/server.rb:12:in<top (required)>’
from
D:/test/vendor/bundle/ruby/1.9.1/gems/puma-1.6.3/lib/puma.rb:14:in
require' from D:/test/vendor/bundle/ruby/1.9.1/gems/puma-1.6.3/lib/puma.rb:14:in<top
(required)>’
from -e:1:in require' from -e:1:in

The weird thing is, if I run this from c:\test, it works just fine.

Here’s some versions:
OS: Windows Server 2008 R2 Standard
Ruby: 1.9.3p448
DevKit: DevKit-tdm-32-4.5.2-20111229-1559-sfx.exe (this is the file I
downloaded, not sure how to get the version from devkit)
Bundler: 1.3.5
Rubygems: 2.0.6

I’ve also attached the Makefile that was in
D:\test\vendor\bundle\ruby\1.9.1\gems\puma-1.6.3\ext\puma_http11.

It’s worth mentioning that when I run the bundle install from d:\test,
it creates a folder
c:\test\vendor\bundle\ruby\1.9.1\gems\puma-1.6.3\ext\puma_http11.gem.20130726-6804-9xfe7q
to which it copies the puma_http11.so file.

I didn’t see any sort of mkmf.log at all either. Not sure what’s going
on.

I don’t remember the details, but iirc, there are some limitations with
the devkit install and drives. I don’t think that it has to be on c:
particularly, but it may be something like it wants to be on the same
drive as “everything else.” Maybe. YMMV.