Problems with "require" when embedding Ruby


#1

I have Ruby interpreter embedded in engine… so far all was good. But
when I tried to require custom extension compiled in .dll(some C++
exported using SWIG) I encountered an error… As far as I know require
simple is searching for .dll or .so with same name… Maybe SWIG
generates bad dll , but standart non embedded Ruby runs this require
very well…
Do you have any advices? Any help will be thanksfull.


#2

Hi,

In removed_email_address@domain.invalid
“Problems with “require” when embedding Ruby” on Tue, 7 Mar 2006
00:59:24 +0900,
Rurouni removed_email_address@domain.invalid wrote:

I have Ruby interpreter embedded in engine… so far all was good. But
when I tried to require custom extension compiled in .dll(some C++
exported using SWIG) I encountered an error…

Are you using rb_require()? If so, try the following:

rb_funcall(Qnil, rb_intern(“require”), 1, rb_str_new2(“YOUR_LIB”));

Thanks,