Problems with Login Engine/rake


#1

Hello,

I have been having problems installing the Login Engine.

I follow all the steps found on the download site (rails-engines.org),
but when I get to the DB_SCHEMA step, I do

rake engine_migrate ENGINE=login in the application root.

“”"

C:\rails\cag> rake engine_migrate ENGINE=login
(in C:/rails/cag)
rake aborted!
Don’t know how to build task ‘engine_migrate’

(See full trace by running task with --trace)

C:\rails\cag> rake engine_migrate ENGINE=login --trace
(in C:/rails/cag)
rake aborted!
Don’t know how to build task ‘engine_migrate’
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1449:in []' c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:455:in[]’
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in run' c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:inrun’
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/bin/rake:7
c:/ruby/bin/rake.bat:25

“”"

I tried doing rake db_schema_import, as well, but it only included the
migrations I had defined for my project and not the login_engine’s
migrations.

Any help would be greatly appreciated.

Regards,
Ryan M.


#2

As of version 1.1, the engines plugin now uses the new namespacing for
rake tasks that you find in Rails 1.1. Make sure you’ve got Rake 0.7
or greater, and run rake -T to see the available tasks.

The one you’re looking for is now called:

rake db:migrate:engines

Documentation for the other available engines should be updated at the
next upcoming release.

  • james

On 4/8/06, Ryan M. removed_email_address@domain.invalid wrote:

Don’t know how to build task ‘engine_migrate’
migrations I had defined for my project and not the login_engine’s
http://lists.rubyonrails.org/mailman/listinfo/rails

  • J *
    ~