Problems with gem rdoc rspec

My gems, e.g. rspec, gets installed in:

(Note the extra /gems/ subdirectory)

When I run “gem rdoc rspec” the output is empty and the Files section
has errors:

file not found -/Library/Ruby/Gems/1.8/rspec-1.2.2/rdoc/License.txt-
file not found -/Library/Ruby/Gems/1.8/rspec-1.2.2/rdoc/Manifest.txt-
file not found -/Library/Ruby/Gems/1.8/rspec-1.2.2/rdoc/examples/
file not found -/Library/Ruby/Gems/1.8/rspec-1.2.2/rdoc/TODO.txt-

(Those are the only files in there. Note the lack of /gems/

Do I need to add /gems/ to my GEM_PATH? I didn’t think that’s how it
works, and my other rubygems build their rdocs fine.

Or do I need to set a different path variable to set this up?
(GEM_HOME? I tried that and it didn’t seem to help.)

Thanks for your help,
Andrew V.

My environment:

$ echo $GEM_PATH

$ more ~/.gemrc

verbose: true
update_sources: true

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs