Problems with !DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN"

When I include in my header, my CSS files no
longer show… they show up in code though, <%= stylesheet_link_tag
‘display’ %> becomes .

I heard Rails is hard-coded to only do XHTML, and that I might have to
do some monkey patching. But I’m clueless as to how.


Mister Blood R.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Mister Blood R. wrote:
| When I include in my header, my CSS files no
| longer show… they show up in code though, <%= stylesheet_link_tag
| ‘display’ %> becomes <link href="/stylesheets/display.css?1208424886"
| media=“screen” rel=“stylesheet” type=“text/css” />.
|
| I heard Rails is hard-coded to only do XHTML, and that I might have to
| do some monkey patching. But I’m clueless as to how.

Here’s a crazy idea: Use XHTML. Learning to properly nest tags and use
self-closing tags isn’t that big of a deal, really. It’s easier than
learning to use Ruby and Rails’ DSL for web apps.


Phillip G.
Twitter: twitter.com/cynicalryan

Will I dream?
~ – HAL-9000
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.8 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkgHPFsACgkQbtAgaoJTgL9+0QCfXWY54cl+JTosAJpeojxBtss4
z3EAoIC8plfCJDHuv2BY2gZHR7DX315l
=J3Jv
-----END PGP SIGNATURE-----

Turned out I had some stale XHTML tags around.

Anyway I’ve heard that future versions of HTML will not be based on
HTML as opposed to XHTML,
hence there’s no point in switching.


Mister Blood R.

On Apr 17, 8:02 pm, Phillip G. [email protected]

Actually my problem didn’t go away.

Considering giving http://dev.turnipspatch.com/trac/wiki/HTMLOutput a
go…

“Are you using XHTML? READ THIS:
http://www.webdevout.net/articles/beware-of-xhtml
, http://hixie.ch/advocacy/xhtml ,
http://www.webdevout.net/articles/validity-and-well-formedness
, http://www.csarven.ca/interview-with-steven-pemberton

From freenode #html

On Apr 17, 8:02 pm, Phillip G. [email protected]

I’m using Apache+mod_rails, like this:

<VirtualHost *:80>
ServerName mysite.com
ServerAlias www.mysite.com
DocumentRoot /services/httpd/mysite.com/public
<Directory “/services/httpd/mysite.com/public”>
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all

RailsBaseURI /

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs