Problems with 1.1.3

Hello all.

I am new to IronRuby and just started. I installed IronRuby 1.1.3, and
then tried to run one of the tutorials. I ran the wpf_tutorial.rb from
C:\Program Files (x86)\IronRuby 1.1\Samples\Tutorial.

System.Core:0:in BindCore': Method not found: 'Microsoft.Scripting.Actions.Calls.OverloadInfo[] Microsoft.Scripting.Actions.Calls.ReflectionOverloadInfo.CreateArray (System.Reflection.MemberInfo[])'. (NoMethodError) from C:/Program Files (x86)/IronRuby 1.1/Lib/ruby/1.9.1/rubygems.rb:152 from C:/Program Files (x86)/IronRuby 1.1/Lib/ruby/1.9.1/rubygems/custom_require.rb:29:inrequire’
from C:/Program Files (x86)/IronRuby
1.1/Lib/ruby/1.9.1/rubygems/custom_require.rb:29:in require' from C:/Program Files (x86)/IronRuby 1.1/Lib/ruby/1.9.1/gem_prelude.rb:142:inload_full_rubygems_library’
from C:/Program Files (x86)/IronRuby
1.1/Lib/ruby/1.9.1/gem_prelude.rb:192:in try_activate' from C:/Program Files (x86)/IronRuby 1.1/Lib/ruby/1.9.1/rubygems/custom_require.rb:32:inrequire’
from wpf_tutorial.rb:32

I checked my environment variables, and I have this:

IRONRUBY_11=C:\Program Files (x86)\IronRuby 1.1\bin
Files\TortoiseSVN\bin;C:\Program Files
(x86)\QuickTime\QTSystem;C:\Program Files (x86)\Microsoft SQL
Server\100\Tools\Binn;C:\Program Files\Microsoft SQL
Server\100\Tools\Binn;C:\Program Files\Microsoft SQL
Server\100\DTS\Binn;C:\Program Files (x86)\IronRuby

Should there be anything else I should configure or investigate?

I also tried running ironruby from VS2010SP1 and #Develop 4.2.1, but
couldn’t really get anywhere, so I tried the tutorials, figuring that
these would work…

  • Joaquin

Did you add references to your project in VS2010?

Make references to IronRuby.dll, IronRuby.Libraries.dll,
Microsoft.Scripting.dll, Microsoft.Scripting.Metadata,

That’s how it works for me.

Does the new installer in 1.1.3 not install these libraries? I was
considering trying to install 1.1, then 1.1.3 over it, as maybe perhaps
the 1.1.3 doesn’t seem work w/ fresh install on clean system.

I searched my system, and I found IronRuby.dll and
IronRuby.Libraries.dll inside:

“C:\Program Files (x86)\Microsoft Visual Studio
10.0\Common7\IDE\Extensions\Microsoft\IronRuby Tools for Visual

For the other DLLS, I couldn’t find this anywhere from the IronRuby
install, I did find some from Iron Python’s installation, such as:

“C:\Program Files (x86)\IronPython 2.7\Platforms\Net40”

  • Joaquin

Message: 7
Date: Thu, 09 Aug 2012 16:06:58 +0200
From: Alexander R. [email protected]
To: [email protected]
Subject: Re: [Ironruby-core] Problems with 1.1.3
Message-ID: [email protected]
Content-Type: text/plain; charset=UTF-8

Did you added references to your project in VS2010?

Make references to IronRuby.dll, IronRuby.Libraries.dll,
Microsoft.Scripting.dll, and Micrsoft.Scripting.Core.dll
Although Microsoft.Dynamic.dll does not need referenced, it must be in
the directory of the executing assembly.

That’s how it works for me.

Posted via

Ironruby-core mailing list
[email protected]

End of Ironruby-core Digest, Vol 58, Issue 1

I uninstalled 1.1.3, and installed 1.0. The tutorials do not work, as
they require rake. However, the code I made (partly auto-generated from
designer with #Develop) works fine. So, it’s a SUCCESS.

I looked at the install, and all the needed dependent libraries are
installed, and required changes to %path%, so that those libraries can
be installed.

I am getting the same issue, but I installed IronRuby from the NuGet

I’m attempting to upgrade the code from this:

I had gotten everything to compile and it got past initial engine load
and assembly loading, but then I get that same message:

Method not found: ‘Microsoft.Scripting.Actions.Calls.OverloadInfo[]

Any other thoughts what it could be?

The versions of those dlls mentioned above:

IronRuby, IronRuby.Libraries :
Microsoft.Dynamic, Scripting, and MetaData:

Thank you,

Encountering the same issue here.

I have references to :


The top of my stack looks like :

MissingMethodException: Method not found:
IronRuby.Builtins.RubyClass.GetConstructors(Type type) +0
metaBuilder, CallArguments args, String methodName) +1862
metaBuilder, CallArguments args, String methodName) +43
metaBuilder, CallArguments args, String name) +109
metaBuilder, CallArguments args, String name) +59
metaBuilder, CallArguments args, String name) +45
metaBuilder, String methodName, CallArguments args, Boolean
defaultFallback, Boolean callClrMethods) +422

I tried a couple of these suggestions however on my machine I have for
some reason 2 instances of IronRuby installed which seems to have
conflicted with what was referenced by the app that I was running even
through the correct .dll’s where in the bin. Uninstalling all instances
and running solved my issues as the bin had what was needed.

I recently installed IronPython for the first time (2.7.5 Beta 2
Installer version). After that I started getting the “System.Core:0:in
`BindCore’: Method not found…” error. I uninstalled both IronPython
and IronRuby 1.1.3, reinstalled IronRuby 1.0, uninstalled IronRuby 1.0,
reinstalled 1.1.3. Then it started working. Glad it’s fixed.

It’s really annoying… The installer puts the assemblies in the Global
Assembly Cache, but it doesn’t put them anywhere else.

The easiest way to get them is from the zip file on the IronRuby website

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs