Problems using ruby:libcrypto.so.0.9.8: open failed: No such


#1

Hi,

I wanted to request help on trying to resolve an error while running a
rb
script. I am a Java developer and also CVS admin for a development
group.I
have been wanting to try Ruby for a while,and when i came across the
cvsspam
ruby script to notify users of cvs commit changes,i decided this was my
chance.

cvsspam requires ruby, and so i installed Ruby 1.8.3 on our CVS Server(
didnt build from source, but got binary ruby-1.8.3-sol9-sparc-local from
sunfreeware.com). Our CVS box runs solaris. I followed the instructions
to
setup ruby and cvsspam and now when i try commiting any file to cvs,the
cvsspam ruby script generates the following error:

/usr/local/lib/ruby/1.8/sparc-solaris2.9/digest/md5.so: ld.so.1:
/usr/local/bin/ruby: fatal: libcrypto.so.0.9.8: open failed: No such
file or
directory - /usr/local/lib/ruby/1.8/sparc-solaris2.9/digest/md5.so
(LoadError)
from /usr/local/lib/ruby/1.8/net/smtp.rb:24
from /cvsroot/CVSROOT/cvsspam.rb:1813
/cvsroot/CVSROOT/collect_diffs.rb:292:in `mailtest’: problem running
‘/cvsroot/CVSROOT/cvsspam.rb’ (RuntimeError)
from /cvsroot/CVSROOT/collect_diffs.rb:449

I also installed the openSSL package(again binaries from sunfreeware)
and
can see the file libcrypto.so.0.9.8 in the servers /user/local/ssl/lib/
directory.

Can anyone please help me out in figuring what went wrong? I desperately
need to track whats happening to my repository and all help is sincerely
appreciated.

Thanks in advance!

Vik.


#2

“v” == vikram shevde removed_email_address@domain.invalid writes:

v> I also installed the openSSL package(again binaries from sunfreeware)
and
v> can see the file libcrypto.so.0.9.8 in the servers
/user/local/ssl/lib/
v> directory.

try to add the directory /user/local/ssl/lib/ in LD_LIBRARY_PATH

Guy Decoux


#3

Thanks for your suggestion Guy! That indeed did work and everythings working properly now.

 

Regards,

Vik.


From: ts <removed_email_address@domain.invalid>
Reply-To: removed_email_address@domain.invalid
To: removed_email_address@domain.invalid (ruby-talk ML)
CC: removed_email_address@domain.invalid
Subject: Re: problems using ruby:libcrypto.so.0.9.8: open failed: No such file
Date: Mon, 21 Nov 2005 19:10:38 +0900
> >>>>> "v" == vikram shevde <removed_email_address@domain.invalid> writes:
>
>v> I also installed the openSSL package(again binaries from sunfreeware) and
>v> can see the file libcrypto.so.0.9.8 in the servers /user/local/ssl/lib/
>v> directory.
>
> try to add the directory /user/local/ssl/lib/ in LD_LIBRARY_PATH
>
>Guy Decoux
>