Problems ./script/server

Hey,

everytime i want to start the server i get the error2 below that there
were problems with gems. So i update them with “gem update” and it
works. But now i get the error1. In the environment i can set the
gem_version to 2.3.5 but after that i will get error2 again. Put it to
gm_version 3.0.0 i will get error1. I don´t know how to solve this.
Could somebody help me? Thanks

ERROR1:

“./script/server
/Library/Ruby/Site/1.8/rubygems.rb:233:in activate': can't activate rails (= 2.3.5, runtime) for [], already activated rails-3.0.0 for [] (Gem::LoadError) from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:35:inrequire’
from /Users/Mark/Rails/studiflex/config/boot.rb:55:in
load_initializer' from /Users/Mark/Rails/studiflex/config/boot.rb:38:inrun’
from /Users/Mark/Rails/studiflex/config/boot.rb:11:in boot!' from /Users/Mark/Rails/studiflex/config/boot.rb:110 from ./script/server:2:inrequire’
from ./script/server:2”

ERROR2:

“./script/server
=> Booting Mongrel
=> Rails 2.3.5 application starting on
http://0.0.0.0:3000/Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/
119:Warning: Gem::Dependency#version_requirements is deprecated and
will be removed on or after August 2010. Use #requirement
/Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
gem_original_require': no such file to load -- /Library/Ruby/Gems/ 1.8/ gems/more-0.1.1/rails/../lib/less/controller_extension (MissingSourceFile) from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:inrequire’
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/
usr/lib/
ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/
dependencies.rb:156:in require' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/ usr/lib/ ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/ dependencies.rb:521:innew_constants_in’
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/
usr/lib/
ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/
dependencies.rb:156:in require' from /Library/Ruby/Gems/1.8/gems/more-0.1.1/rails/init.rb: 1:inevaluate_init_rb’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/
plugin.rb:
158:in evaluate_init_rb' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/ usr/lib/ ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/core_ext/ kernel/reporting.rb:11:insilence_warnings’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/
plugin.rb:
154:in evaluate_init_rb' from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/ plugin.rb: 48:inload’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/
plugin/
loader.rb:38:in load_plugins' from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/ plugin/ loader.rb:37:ineach’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/
plugin/
loader.rb:37:in load_plugins' from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/ initializer.rb: 369:inload_plugins’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/
initializer.rb:
165:in process' from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/ initializer.rb: 113:insend’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/
initializer.rb:
113:in run' from /Users/Mark/Rails/studiflex/config/environment.rb:8 from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
require' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/ usr/lib/ ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/ dependencies.rb:156:inrequire’
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/
usr/lib/
ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/
dependencies.rb:521:in new_constants_in' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/ usr/lib/ ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/ dependencies.rb:156:inrequire’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/commands/
server.rb:
84
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:inrequire’
from ./script/server:3”
When i change it to version 2.3.5 i will get this message. If i turn
it back to 3.0.0 i will get this message:
“./script/server
/Library/Ruby/Site/1.8/rubygems.rb:233:in activate': can't activate rails (= 2.3.5, runtime) for [], already activated rails-3.0.0 for [] (Gem::LoadError) from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:35:inrequire’
from /Users/Mark/Rails/studiflex/config/boot.rb:55:in
load_initializer' from /Users/Mark/Rails/studiflex/config/boot.rb:38:inrun’
from /Users/Mark/Rails/studiflex/config/boot.rb:11:in boot!' from /Users/Mark/Rails/studiflex/config/boot.rb:110 from ./script/server:2:inrequire’
from ./script/server:2”

Could anybody help? Don´t know.
Thanks

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs