Problems rake db:create

Hi,

i have some problems by type in rake db:create

It always says:

rake aborted!
can’t activate rails (= 2.3.5, runtime) for [], already activated
rails-3.0.0 for []

I have set Rails version to 2.3.5 but the problem still exists.
I want to install the OpenSource Project webpraca. Maybe somebody has
the same problem.

Thanks for help

Since you have both RAILS 3.0.0 and 2.3.5, RAILS 3.0.0 is gettting
loaded
first.

You can either uninstall the RAILS 3.0.0 GEM, or migrate your RAILS
2.3.5
App to use bundler. (http://gembundler.com/rails23.html).

Regards,
Srikanth

Ah okay. That works.
I have uninstalled 3.0.0. (For them with the same problem: gem
uninstall rails --version 3.0.0)

Thank you Srikanth

Mark wrote:

Hi,

i have some problems by type in rake db:create

It always says:

rake aborted!
can’t activate rails (= 2.3.5, runtime) for [], already activated
rails-3.0.0 for []

I have set Rails version to 2.3.5 but the problem still exists.

How have you done this? The correct way involves setting
RAILS_GEM_VERSION in config/environment.rb. Is that what you did?

There was no need for you to remove Rails 3. Your project should still
be able to run the older version.

I want to install the OpenSource Project webpraca. Maybe somebody has
the same problem.

Thanks for help

Best,
–Â
Marnen Laibow-Koser
http://www.marnen.org
[email protected]

Sent from my iPhone

Hey thanks for your answer

I have done it like you said and changed it in the environment.
But now i will get a bigger issue:

“./script/server
=> Booting Mongrel
=> Rails 2.3.5 application starting on http://0.0.0.0:3000
/Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/gem_dependency.rb:
119:Warning: Gem::Dependency#version_requirements is deprecated and
will be removed on or after August 2010. Use #requirement
/Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
gem_original_require': no such file to load -- /Library/Ruby/Gems/1.8/ gems/more-0.1.1/rails/../lib/less/controller_extension (MissingSourceFile) from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:inrequire’
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/
dependencies.rb:156:in require' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/ dependencies.rb:521:innew_constants_in’
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/
dependencies.rb:156:in require' from /Library/Ruby/Gems/1.8/gems/more-0.1.1/rails/init.rb:1:inevaluate_init_rb’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/plugin.rb:
158:in evaluate_init_rb' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/core_ext/ kernel/reporting.rb:11:insilence_warnings’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/plugin.rb:
154:in evaluate_init_rb' from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/plugin.rb: 48:inload’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/plugin/
loader.rb:38:in load_plugins' from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/plugin/ loader.rb:37:ineach’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/plugin/
loader.rb:37:in load_plugins' from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb: 369:inload_plugins’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
165:in process' from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb: 113:insend’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
113:in run' from /Users/Mark/Rails/studiflex/config/environment.rb:8 from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
require' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/ dependencies.rb:156:inrequire’
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/
dependencies.rb:521:in new_constants_in' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/ dependencies.rb:156:inrequire’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/commands/server.rb:
84
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:inrequire’
from ./script/server:3”

When i change it to version 2.3.5 i will get this message. If i turn
it back to 3.0.0 i will get this message:

“./script/server
/Library/Ruby/Site/1.8/rubygems.rb:233:in activate': can't activate rails (= 2.3.5, runtime) for [], already activated rails-3.0.0 for [] (Gem::LoadError) from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:35:inrequire’
from /Users/Mark/Rails/studiflex/config/boot.rb:55:in
load_initializer' from /Users/Mark/Rails/studiflex/config/boot.rb:38:inrun’
from /Users/Mark/Rails/studiflex/config/boot.rb:11:in boot!' from /Users/Mark/Rails/studiflex/config/boot.rb:110 from ./script/server:2:inrequire’
from ./script/server:2”

Could anybody help? Don´t know.

Thanks

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs