Problems on os x tiger (with xcode 2.2)


#1

It appears that I’m able to install and update just about everything,
however when i try and run rails [project] I keep getting this error
message:
Rails requires Ruby version 1.8.2 (2004-12-25) or later.
You’re running 1.8.2 (2004-11-03); please upgrade to continue.

I have tried to run this (which appears to have worked, but not solved
the issue):
http://www.tonyarnold.com/articles/2005/08/10/rolling-with-ruby-on-rails-on-mac-os-x-tiger-for-beginners

I found this:
http://hivelogic.com/articles/2005/12/01/ruby_rails_lighttpd_mysql_tiger
which recommends actually building ruby, but I haven’t seen others
with this issue on the list, is this really what I need to do?

Just starting a new project after playing around with this on panther
and would like to get back on track again.

-warner


#2

On Dec 8, 2005, at 13:22 , Warner O. wrote:

I found this:
http://hivelogic.com/articles/2005/12/01/
ruby_rails_lighttpd_mysql_tiger
which recommends actually building ruby, but I haven’t seen others
with this issue on the list, is this really what I need to do?

That’s what I did. It’s painless. Dan Benjamin’s instructions are
clear and easy to follow.

Michael G.
grzm myrealbox com


#3

Michael G. wrote:

and easy to follow.
I agree.

But first double-check that you have whatever new Ruby, gem and Rails
you installed on your PATH, e.g.

$ which ruby
/usr/local/bin/ruby
$ ruby -v
ruby 1.8.2 (2004-12-25) [powerpc-darwin8.3.0]

regards

Justin


#4

Warner O. wrote:

It appears that I’m able to install and update just about everything,
however when i try and run rails [project] I keep getting this error
message:

Check out Locomotive.

–Steve