Problems installing Rmagick on Ubuntu

I want to install Rmagick on Ubuntu 7.10, but i am getting this error
when running gem install rmagick:

Can’t install RMagick 2.2.0. You must have ImageMagick 6.3.0 or later.

(I installed imagemagick and libmagick9-dev prior to that)

I installed rmagick through Synaptic, and it says that i have version
7:6.2.4.5.dfsg1-2ubuntu1 installed (by the way, what does the 7
mean?). What should i do to have the gem install correctly?

On 2/4/08, Peter [email protected] wrote:

mean?). What should i do to have the gem install correctly?
Is it possible you need to run ldconfig? Or add something to your
/etc/ld.so.conf ?


Greg D.
http://destiney.com/

I know for 6.06 there is a libmagick-ruby library that needs to be
installed as well.

  • Richard

On Feb 4, 9:59 pm, “Greg D.” [email protected] wrote:

I installed rmagick through Synaptic, and it says that i have version
7:6.2.4.5.dfsg1-2ubuntu1 installed (by the way, what does the 7
mean?). What should i do to have the gem install correctly?

Is it possible you need to run ldconfig? Or add something to your
/etc/ld.so.conf ?


Greg D.http://destiney.com/

I have no idea, should i? And if so: how? :slight_smile:
I’m a newbie to Ubuntu…

And I have libmagick-ruby and libmagick-ruby1.8 installed.

Peter wrote:

I want to install Rmagick on Ubuntu 7.10, but i am getting this error
when running gem install rmagick:

Can’t install RMagick 2.2.0. You must have ImageMagick 6.3.0 or later.

(I installed imagemagick and libmagick9-dev prior to that)

I installed rmagick through Synaptic, and it says that i have version
7:6.2.4.5.dfsg1-2ubuntu1 installed (by the way, what does the 7
mean?). What should i do to have the gem install correctly?

RMagick 2.2.0 is for ImageMagick 6.3.0 or later. For older versions of
ImageMagick, use RMagick 1.15.12:

gem install rmagick -v 1.15.12

See http://rmagick.rubyforge.org/rmagick2.html.

This should do the trick.

sudo apt-get install ruby rubygems irb ri rdoc ruby1.8-dev build-
essential imagemagick libmagick9 libmagick9-dev

sudo gem install rmagick -v=1.15.10

[email protected]:~$ irb
irb(main):001:0> require ‘rubygems’
=> true
irb(main):002:0> require ‘RMagick’
=> true
irb(main):003:0> Magick::CenterGravity
=> CenterGravity=5
irb(main):004:0>

On Feb 5, 8:24 am, “[email protected][email protected]

Could someone ‘sew up’ this topic and possibly list what one must do
to install RMagick upon a Ubuntu 7.10 configuration?
I would be most grateful as I too, am like many who have failed at
this endeavor.
Thank you,
Kathleen

On Feb 4, 6:50 pm, Tim H. [email protected]

Hi Thanks,

It is very helpful for me.

Shrikant

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs