Problems installing gems


#1

Hey everyone…

I’m using Linux with Fedora Core 2. I decided last night I want to try
and install ruby and rails. Ruby installed very easily, it was a lot
less painless than I thought. Next I needed to install Gems, upon
attempting to install Gems I realized I also don’t have zlib-0.6.0. I
followed directions (
http://wiki.rubyonrails.com/rails/pages/RailsOnFedora) and used “sudo
yum install zlib-devel”. This installation was successful.

After thinking I had zlib installed I decided to try and install
Gems…packages all extract correctly, but installing I run into these
snags:

As of RubyGems 0.8.0, library stubs are no longer needed.
Searching $LOAD_PATH for stubs to optionally delete (may take a
while)…
…done.
No library stubs found.

/root/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__': no such file to load -- zlib (LoadError) from /root/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from /root/lib/ruby/site_ruby/1.8/rubygems/package.rb:9
from
/root/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in require' from /root/lib/ruby/site_ruby/1.8/rubygems/builder.rb:1 from /root/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from /root/lib/ruby/site_ruby/1.8/rubygems.rb:61:in
manage_gems' from /home/httpd/vhosts/cambridgecreative.net/httpdocs/rubygems-0.8.11/./post-install.rb:64:ininstall_sources’
from
/home/httpd/vhosts/cambridgecreative.net/httpdocs/rubygems-0.8.11/./post-install.rb:75:in
instance_eval' from setup.rb:583:intry_run_hook’
from setup.rb:577:in run_hook' from setup.rb:1315:inexec_task_traverse’
from setup.rb:1168:in exec_install' from setup.rb:887:inexec_install’
from setup.rb:705:in invoke' from setup.rb:674:ininvoke’
from setup.rb:1352
[root@u15194085 rubygems-0.8.11]#
/root/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__’: no such file to load – zlib (LoadError)


Any ideas what my problem can be? I thought this Rails installation was
going to be easy but now that I’m about 5 hours deep I am rethinking
that…Any help you can give me would be much appreciated.

Thanks a lot.


#2

After you installed zlib library, you need to recompile Ruby. zlib
extension
is missing.

Kent.