Problems getting started

i’ve run update and update system… now, when i run script/server I
get this output:

-------------snip-----------------

/opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:777:in
report_activate_error': RubyGem version error: rack(1.0.0 not ~> 1.0.1) (Gem::LoadError) from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:211:inactivate’
from /opt/local/lib/ruby/site_ruby/1.8/rubygems.rb:1056:in gem' from /opt/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/ action_controller.rb:34 from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 31:ingem_original_require’
from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in require' from /opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/ active_support/dependencies.rb:156:inrequire’
from /opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:521:in new_constants_in' from /opt/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/ active_support/dependencies.rb:156:inrequire’
from /opt/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/commands/
server.rb:2
from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in gem_original_require' from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 31:inrequire’

-------------snip-----------------

any thoughts?

TIA,

J

On Tue, Apr 20, 2010 at 3:04 AM, JSF [email protected] wrote:

`report_activate_error’: RubyGem version error: rack(1.0.0 not ~>
1.0.1) (Gem::LoadError)

That’s the source of the error, you need to update your rack gem.
Try:

gem install rack -v 1.0.1

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs