Problemi dopo update di alcune gems

Ho fatto l’update di alcune gem, tra cui rails da 3.0 a 3.0.1 e
bundler ed ora mi ritrovo col seguente errore:

bundle install
/home/user/jruby/lib/ruby/site_ruby/1.8/rubygems/package/tar_input.rb:111:in
`initialize’: No metadata found! (Gem::package::FormatError)

Ma percheeeeeeeeeeeeeeee???

ciao Mauro,

prova a cancellare la cache in vendor/ e controlla che non ci sia anche
un .bundle/cache nella root della app. quando mi capitato, ho risolto
cos.

ad ogni modo, dai una letta anche qui:
https://github.com/carlhuda/bundler/issues/issue/184

e qui:

https://github.com/carlhuda/bundler/issues/#issue/704

a quanto pare, c’ di mezzo anche $GEM_HOME/cache

ciao,
A.

Il 04/11/2010 17:43, Mauro ha scritto:

2010/11/4 Andrea P. [email protected]:

ciao Mauro,

prova a cancellare la cache in vendor/ e controlla che non ci sia anche
un .bundle/cache nella root della app. quando mi capitato, ho risolto
cos.

Risolto cancellando la cache.