Problemi di partenza

Salve a tutti !! ieri sera ho deciso finamente di installare ruby on
rails, una volta completata la guida sul sito ufficiale testo subito il
software.

Creo come da manuale una nuova applicazione, ma quando la lancio con il
solito comando ruby script/server mi ritrovo davanti alla pagina html
dellìapplicazione con il seguente errore:

We’re sorry, but something went wrong.

We’ve been notified about this issue and we’ll take a look at it
shortly.

gli errori


 Status: 500 Internal Server Error
  no such file to load -- sqlite3
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
    /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:156:in
`require'
    /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:521:in
`new_constants_in'
    /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:156:in
`require'
    /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_support/core_ext/kernel/requires.rb:7:in
`require_library_or_gem'
    /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_support/core_ext/kernel/reporting.rb:11:in
`silence_warnings'
    /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.4/lib/active_support/core_ext/kernel/requires.rb:5:in
`require_library_or_gem'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/sqlite3_adapter.rb:10:in
`sqlite3_connection'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_pool.rb:223:in
`send'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_pool.rb:223:in
`new_connection'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_pool.rb:245:in
`checkout_new_connection'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_pool.rb:188:in
`checkout'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_pool.rb:184:in
`loop'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_pool.rb:184:in
`checkout'
    /usr/local/lib/ruby/1.8/monitor.rb:242:in `synchronize'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_pool.rb:183:in
`checkout'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_pool.rb:98:in
`connection'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_pool.rb:326:in
`retrieve_connection'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_specification.rb:123:in
`retrieve_connection'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_specification.rb:115:in
`connection'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/query_cache.rb:9:in
`cache'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/query_cache.rb:28:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_pool.rb:361:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/rack-1.0.0/lib/rack/head.rb:9:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/rack-1.0.0/lib/rack/methodoverride.rb:24:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/params_parser.rb:15:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/session/cookie_store.rb:93:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/failsafe.rb:26:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/rack-1.0.0/lib/rack/lock.rb:11:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/rack-1.0.0/lib/rack/lock.rb:11:in
`synchronize'
    /usr/local/lib/ruby/gems/1.8/gems/rack-1.0.0/lib/rack/lock.rb:11:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:114:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/reloader.rb:34:in
`run'
    /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:108:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/rails-2.3.4/lib/rails/rack/static.rb:31:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/rack-1.0.0/lib/rack/urlmap.rb:46:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/rack-1.0.0/lib/rack/urlmap.rb:40:in
`each'
    /usr/local/lib/ruby/gems/1.8/gems/rack-1.0.0/lib/rack/urlmap.rb:40:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/rails-2.3.4/lib/rails/rack/log_tailer.rb:17:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/rack-1.0.0/lib/rack/content_length.rb:13:in
`call'
    /usr/local/lib/ruby/gems/1.8/gems/rack-1.0.0/lib/rack/handler/webrick.rb:46:in
`service'
    /usr/local/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
    /usr/local/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
    /usr/local/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
    /usr/local/lib/ruby/1.8/webrick/server.rb:162:in `start'
    /usr/local/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
    /usr/local/lib/ruby/1.8/webrick/server.rb:95:in `start'
    /usr/local/lib/ruby/1.8/webrick/server.rb:92:in `each'
    /usr/local/lib/ruby/1.8/webrick/server.rb:92:in `start'
    /usr/local/lib/ruby/1.8/webrick/server.rb:23:in `start'
    /usr/local/lib/ruby/1.8/webrick/server.rb:82:in `start'
    /usr/local/lib/ruby/gems/1.8/gems/rack-1.0.0/lib/rack/handler/webrick.rb:13:in
`run'
    /usr/local/lib/ruby/gems/1.8/gems/rails-2.3.4/lib/commands/server.rb:111
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
    script/server:3

cos altro dovrei installare ?!

2009/9/29 Ge Ge [email protected]:

Salve a tutti !! ieri sera ho deciso finamente di installare ruby on
[snip]

no such file to load – sqlite3
Credo tu debba installare sqlite3 per la tua piattaforma.

Ciao ciao
thesp0nge

“stay hungry, stay foolish”

OWASP Orizon project, http://orizon.sourceforge.net
“enjoy your code review experience”

eh si infatti però quando provo ad installarla :

gem install sqlite3-ruby
WARNING: Installing to ~/.gem since /usr/local/lib/ruby/gems/1.8 and
/usr/local/bin aren’t both writable.
WARNING: You don’t have /Users/alex/.gem/ruby/1.8/bin in your PATH,
gem executables will not run.
Building native extensions. This could take a while…
Successfully installed sqlite3-ruby-1.2.5
1 gem installed
Installing ri documentation for sqlite3-ruby-1.2.5…

No definition for _wrap_new_CallbackData

No definition for _wrap_CallbackData_proc_set

No definition for _wrap_CallbackData_proc_get

No definition for _wrap_CallbackData_proc2_set

No definition for _wrap_CallbackData_proc2_get

No definition for _wrap_CallbackData_data_set

O_o…

Come scritto nella mia mail, devi avere privilegi di amministratore.
Se (come presumo) sei su linux usa sudo gem install o comando
equivalente.

Riguardo ai messaggi di warning, si riferiscono alla generazione della
documentazione. E’ possibile che qualche elemento non sia stato
interpretato
correttamente da RDoc. Non preoccuparti, la gem è stata comunque
installata
correttamente.

– Simone

On Tue, Sep 29, 2009 at 11:33 AM, Ge Ge [email protected] wrote:

Installing ri documentation for sqlite3-ruby-1.2.5…

http://lists.ruby-it.org/mailman/listinfo/ml


Simone C.

Site & Blog: http://www.simonecarletti.com
Email: [email protected]
LinkedIn: http://linkedin.com/in/weppos
Nick: weppos | Skype: weppos

Supponendo che sqlite3 sia installato, tI manca la gem sqlite.

gem install sqlite3-ruby

TI servono i privilegi di amministratore per completare l’installazione.
Se sqlite3 non è installato, prima devi installare anche sqlite3 via
sorgente o pacchetto.

– Simone

On Tue, Sep 29, 2009 at 11:11 AM, Ge Ge [email protected] wrote:

We’ve been notified about this issue and we’ll take a look at it
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in

sqlite3_connection' /usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_pool.rb:188:incheckout’
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstract/connection_specification.rb:115:in
/usr/local/lib/ruby/gems/1.8/gems/rack-1.0.0/lib/rack/head.rb:9:in

call'call’

/usr/local/lib/ruby/1.8/webrick/server.rb:23:in `start’

[/code]

cos altro dovrei installare ?!

Posted via http://www.ruby-forum.com/.


Ml mailing list
[email protected]
http://lists.ruby-it.org/mailman/listinfo/ml


Simone C.

Site & Blog: http://www.simonecarletti.com
Email: [email protected]
LinkedIn: http://linkedin.com/in/weppos
Nick: weppos | Skype: weppos

Simone C. wrote:

Come scritto nella mia mail, devi avere privilegi di amministratore.
Se (come presumo) sei su linux usa sudo gem install o comando
equivalente.

Riguardo ai messaggi di warning, si riferiscono alla generazione della
documentazione. E’ possibile che qualche elemento non sia stato
interpretato
correttamente da RDoc. Non preoccuparti, la gem � stata comunque
installata
correttamente.

– Simone

On Tue, Sep 29, 2009 at 11:33 AM, Ge Ge [email protected] wrote:

Installing ri documentation for sqlite3-ruby-1.2.5…

http://lists.ruby-it.org/mailman/listinfo/ml

ti ringrazio per il consiglio ma ora mi dà quest errore:

ERROR: While executing gem … (Gem::CommandLineError)
Please specify at least one gem name (e.g. gem build GEMNAME)

cmq mi trovo su una piattaforma Apple, più precisamente leopard 10.5.8


Simone C.

Site & Blog: http://www.simonecarletti.com
Email: [email protected]
LinkedIn: http://linkedin.com/in/weppos
Nick: weppos | Skype: weppos

2009/9/29 Ge Ge [email protected]:

ti ringrazio per il consiglio ma ora mi dà quest errore:

ERROR: While executing gem … (Gem::CommandLineError)
Please specify at least one gem name (e.g. gem build GEMNAME)
Perché devi scrivere tutto il pezzo: sudo gem install sqlite3-ruby

Ciao ciao
Paolo


“stay hungry, stay foolish”

OWASP Orizon project, http://orizon.sourceforge.net
“enjoy your code review experience”

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs