Probleme Dépendance rails/rake


#1

Salut,

J’ai (encore) un petit problème. J’utilise ruby (sous windows,
linux…) version 1.8.6 avec rails 2.1.0 et j’ai des petits problèmes de
dépendances.
Je dispose de plusieurs projets Ror avec dans le fichier de
configuration (configuration.rb) la version gem de rails 2.1.0.

J’ai toujours un message d’erreur lié à rake. J’ai donc installé une
version antérieur de rake (0.7.3). Actuellement, je dispose de deux
version 0.7.3 et 0.8.4 dans la mesure ou, apparemment, la dernière est
utile pour la prise en compte de rails 2.1.0.

Je résume la situation :

  • soit je tourne avec rake 0.7.3 et je n’ai plus le message d’erreur lié
    Ã rake mais un autre me demandant de faire un “gem install -v=2.1.0
    rails”.
  • soit je tourne avec rake 0.7.3 et 0.84 et j’ai un message d’erreur lié
    Ã rake dans mon netbeans 6.5

Je précise que je n’utilise pas JRuby et que tout est bien configuré
pour utiliser ruby dans mon netbeans.

Sachant que je tourne en rond, auriez-vous une idée pour sortir de cette
boucle infinie ?

Merci


#2

Problème résolu!