Probleme builder


#1

Bonjour,

Je n’arrive pas à utiliser builder sous ruby avec ubuntu alors que ça
fonctionne sous Netbeans.

Mon paquet gem est bien installé (builder 2.1.2) cependant dès que je
fais un require ‘builder’, j’obtiens le message d’erreur suivant :

uninitialized constant Builder (NameError)
from …/./applicationRuby.rb:1134


#2

Le 18 mai 09 à 16:27, Babiben ***** a écrit :

from …/./applicationRuby.rb:1134
Ton gem n’est surement pas installé pour ton serveur. En effet,
netbeans a la facheuse habitude d’utiliser son propre gestionnaire de
gem qui n’est pas forcement disponible pour ton application.

Si tu utilises bien le config.gem tu peux vérifier que tu as bien le
gem ou l’installer avec la commande rake gems:install ou rake gems

Cyril M.
http://blog.shingara.fr


#3

Comment je peux savoir quel est le gem que j’utilise ? J’ai l’impression
que j’en ai plusieurs sur la machine. J’ai essayé de désintaller les
paquets gem et gem sur ubuntu et en tapant la commande gem --version, je
pouvais toujours accéder à ma version. C’est louche tout de même ?

Il n’y a pas un moyen de supprimer tout ce qui concerne gems et de le
réinstaller proprement car j’ai l’impression que sur cette machine, il y
a différentes versions…


#4

Bonjour,

Pour le paquet gem lui-même je ne sais pas, mais pour les gems je
m’étais
retrouvé avec un problème similaire où une partie des gems était
installée
dans un répertoire et une autre partie des gems dans un autre
répertoire,
selon que je les avais installées avec “gem install” ou “sudo gem
install”.
Tu peux voir le ou les répertoires où sont installées tes gems avec la
commande “gem env paths” et regarder à l’intérieur de ces répertoires
quelles gems y sont installées. Tu peux désinstaller toutes les gems
d’un
certain répertoire avec l’option --install-dir de gem uninstall.

Je ne sais pas si cela correspond à ta situation, peut-être cela
t’aidera-t-il…

Florent

Le 19 mai 2009 04:00, Babiben ***** removed_email_address@domain.invalid a
écrit :


#5

En fait, j’ai “nettoyé” les fichiers liés à rubygems. J’ai tout
réinstallé proprement. Je me suis retrouvé avec l’erreur =>
/usr/bin/gem:10: undefined method `manage_gems’ for Gem:Module
(NoMethodError)

J’ai suivi l’explication fournie ici
(http://www.videc.at/2009/04/30/rubygems-undefined-method-manage_gems-for-gemmodule-nomethoderror/)
et la situation s’est arrangée.

merci quand même pour les infos.