Probleme avec "auto_complete_for"


#1

Bonjour,
je découvre RoR combiné avec de l’Ajax mais je me heurte à cetains
problème. En voulant appliquer le helper
“|text_field_with_auto_complete|” je n’arrive pas à obtenir le rendu
visuel que l’on peut observer ici
http://demo.script.aculo.us/ajax/autocompleter”.
voici mon code adapté à mon besoin:

|# view
Just a little test:
<%= text_field_with_auto_complete :employees, :nom%>

controller

class…
auto_complete_for ||:employees, :nom

def uneAutreMethode

end|||

end
Avec dans ma BD une table “employees” et une colonne “nom”

Merci d’avance pour votre aide.

moufid


#2

moufid zeribi wrote:

Bonjour,
je d�couvre RoR combin� avec de l’Ajax mais je me heurte � cetains
probl�me. En voulant appliquer le helper
“|text_field_with_auto_complete|” je n’arrive pas � obtenir le rendu
visuel que l’on peut observer ici
http://demo.script.aculo.us/ajax/autocompleter”.
voici mon code adapt� � mon besoin:

|# view
Just a little test:
<%= text_field_with_auto_complete :employees, :nom%>

controller

class…
auto_complete_for ||:employees, :nom

def uneAutreMethode

end|||

end
Avec dans ma BD une table “employees” et une colonne “nom”

Merci d’avance pour votre aide.

moufid

la solution au problème est dans cette ligne :
<%= javascript_include_tag :defaults %>
et par l’inclusion des librairies qui vont bien dans public/javascripts/
(scriptaculous.js…), et par la mise au singulier de la table, soit
:employees!!


#3

kysen wrote:

moufid zeribi wrote:

la solution au problème est dans cette ligne :
<%= javascript_include_tag :defaults %>
et par l’inclusion des librairies qui vont bien dans public/javascripts/
(scriptaculous.js…), et par la mise au singulier de la table, soit
:employees!!

J’ai le même code que mon ami avec les bonnes librairies + la ligne que
tu as spécifié mais ca ne marche pas !!! Please help me !!